Computer security policy isn't specifying the policies right

1.-When I run a program and comodo asks me if it can access the protected interface I click on “allow this request” and “remember my answer” but when I go check is recorded on the “ask” column.

2.-Another problem is that when I click on remember answer for the specified function, if the application wants to perform a similar function it asks me again as if it didn’t remember my previous choice and this goes on until I finish the entire cycle of processes which makes me want to disable Defense+ for the time being.

Another problem I just noticed, when I create a manual policy and set “protected com interfaces” to “allow” when I run this application it still asks me for that access.

One last bug, is when when the question “program could not be recognized allow connection?” I select yes and remember answer, but if the program wants to do a second connection without it being finished it ask me the same question, I mention something similar for the protected interface, but this case the firewall adds a second rule containing the same information.


The first 2 “bugs” were not such, it was my fault, they are different requests, although it would be nice if they would add option to allow all request of the same kind instead of manually adding 80 or 100 protected registry keys manually.

the third problem doesn’t happen anymore on the newer version.