Computer is locked after auto downloading update! [Resolved]

My laptop just downloaded and installed an auto update for comodo. It then prompted me to reboot. So I rebooted and now will not do anything after I login it just sits there at the desktop. When I move the mouse down over the task bar it just turns to the hourglass.
I am running CAVS, Firewall, and i-Vault.

Please help I am at work and use this laptop for work and it is pretty much useless now.

Hi, Pov-Rev

Please help I am at work and use this laptop for work and it is pretty much useless now.
Have you tried turning the laptop off for a few minutes, then restart.

Or try going in to Safe Mode to get into Windows, then bring up CAV and try doing a scan.

Take Care,
TheQuest 8)

I had the same problem on two separate machines. See my post about the same thing earlier today…

Im glad to see its not me, but Im sorry for your troubles.

I was able to use the Windows XP System Restore to get back before the update happened, and I disabled automatic updating until I figure out what happened.

If you are running Windows ME or XP you should be able to restore to an earlier time after booting to safemode…

Hopefully someone can figure out why there are the issues with the update…

Hi, Clarkbug

I have just tried the update on W2k and XP Pro, with no problem.

So it looks like the is a conflict with some driver or App that you and Pov-Rev both have installed.

Take Care,
TheQuest 8)


I had the same problem after rebooting after installing the Ashampoo defragmenter product, I rebooted for the CAVS update and my system froze, then I went into safemode uninstalled the Ashampoo product and everything was find, it was strange, but you don’t happen to have any Ashampoo products installed right now or have had them installed in the past have you?

Yes I have tried to reboot, that was the first thing I did Multipal times. :-[

I also attempted to go into safe mode and uninstall this software but it will not uninstall!!!???


And To be clear it was not the auto windows update that caused this it was the Comodo Auto Updater.

I guess my only option is to delete the Comodo folder from program files and if that doesn’t work I guess I am only left with formating and reinstall.

:‘( :’( :‘( :’( :‘( :’( :‘( :’( :‘( :’( :‘( :’(

I was not saying that you did not try to reboot. Also why not just delete Comodo from startup? That would be more simple, then after you delete the startup entry boot normaly and see if you freeze up, if you don’t freeze up then uninstall CAVS until this issue is addressed by the Comodo Antivirus department.

No I don’t have that software and have not installed anything new on the system for almost a year.
I just have Visual Studio Installed and Visual Voxpro 9 installed nothing else.
Basicly just my barebones work development laptop.
It is going to tick me off if I end up having to reinstall.

Hi there.

I dont really know what sort of similarities would be between all three machines…

I know that both that I were working on were Dell systems, running Win XP SP2. Other than that, I dont know whats the same. Mine is a Dimension, the other is an optiplex. They dont share much of the same hardware at all, and there isnt lots of additional software installed on either machine. Also, there is no visual studio or anything like that running on my system.

When I tried removing the AV from the startup, that did not fix the problem. I think it must be one of the services that starts in the background that is just becoming a resource hog or something.

Other posts on this forum have said something about the winsock updating, perhaps its something to do with that…

I just know I would like to be able to update my virus scanner, but not if I cant use my machine…

I had exactly the same prob that you all are experiencing but seems to be solved now. I just left the machine running for about 20 mins while I was searching for a solution to the problem and when I returned it was fine.

I also removed the launch pad, firewall, and antivirus from the startup in the registry but that didn’t work. But it was a first step.

Here is what I did:

  1. Start XP in Safe mode.
  2. Remove Comodo Launcher and any other Comodo software from startup using regedit - HKEY_LOCAL_MACHINE->Software->Microsoft->Windows->Current Version->Run.
  3. Rename the \Program Files\Comodo folder to \Program Files\Comodo.bak.
  4. Reboot.
  5. As XP Loads up it will keep trying to run the installer for comodo, each time it does just click cancel. Also if it seems to lock after choosing your user, typing your password and hitting enter then press ALT-Tab and it will change you over to the installer that is trying to go in the back ground, click the cancel button. After that the installer will try to run a few more times as windows finishes loading, just keep clicking cancel.
  6. Go back to your Program Files folder and rename the Comodo.bak back to Comodo.
  7. Then go into the Control Panel and choose Add Remove Programs and remove each application and don’t reboot untill you have removed them all.

I was running Windows XP Pro SP2 on my laptop. Now for the kicker, my desktop machine is basicly the exact same as my laptop and when I came into work and turned them both on they both auto updated comodo at the same time and I rebooted them at the same time my desktop came up and worked just fine but my laptop locked on the desktop after logging in. Kinda frustrating. I ended up reloading avg on the laptop which I will run for a few months and then try comodo again. I really like it and will continue to use it on my desktop machine since I haven’t had any probs with it.

So much for what I said previously, rebooted the machine and couldnt do anything again. Going to stop the service until a fix is released.

Hi, Pov-Rev and Clarkbug

I must say sorry, I was wrong about Your two OS. [Drivers and Apps] :-[

I ran another test on W2k, wiped my HDD restored W2k with no FW or AV, installed CPF [beta] and Nod32 updated Nod32 rebooted and uninstalled Nod32 [deleated any ESET folders] and did a good clean with jv16.

Installed CAV updated rebooted to Your same problem.

Tried to uninstall through Control Panel received error about Windows Uninstaller not in stalled properly, so went to WINNIT [it is WINDOWS folder on XP] folder> Downloaded Installation>Comodo Anti-Virus 1+ Installer and trie its uninstaller but received same error.

The Problem seem to be the Update is some how not installing it self properly.

Take Care,
TheQuest 8)

Just a question, (and forgive me if I missed it in your other posts) do you have an actual store bought full version xp? Or do you have an OEM or pre installed XP? There are a few repair options here and no need to jump into a re=install right away.


The keys may vary, but typically tap the F8 or F9,F10 ,F11 ,F12 or F1 or F2. This is a varient on different machines but typically tap the key and you may come to some repair options. F1 , F2 typically bring you into Cmos setup which you don’t want. So F8 -F12 will bring you some options and F8 is typically safe mode which you probably know. If you can bring up the options screen, choose last known good configuration. Since you already tried safe mode, is there a repair\non destructive recovery option? You may try tapping R at boot to get into some recovery option and do a non destructive repair. Once again, if OEM you may have a recovery partition, or disk\s or can order them.

If not OEM…(Full)

You can do a fake install and go to repair. If you boot from the disk and go into setup as if you were installing, you will see and option to repair the installation. Here is one of many links…

There are other ways without doing a complete reinstall, especially with a full version. If you can in fact get into safe mode, you should have done a system restore for a first step. If you fear you will lose anything, back up your information (which you should do anyway) and then attempt the repair.

( Many times these steps will get your pc back to running order nicely.) (:KWL)

I have to ask, did you possibly interrupt the update process or run other programs? Doing this can cause major grief from any Anti-V or firewall. I just fixed my son's last night as he interrupted (couldn't wait for update) messed around a bit and his Anti-v wouldn't update any more, said it needed to be registered, when the only registration is when you put the disk in with the key, had to restart with disk and repair as well. Updates should be taken more seriously when being put on a pc but many don't know this, like me, when I run my security updates, I put it off until I can stop any outright running programs and this seems to work best.  <This is just FYI and I am in no way saying you did this, I have gotten thrashed upon for even mentioning some may have made a mistake , lolll, so I want to make this clear that it's NOT an accusation.  ;) >  

Just some info if you feel you are stuck…



Thanks for the additional input, its always good to try and have opinions on this sort of thing.

I actually had two different installs running depending on which machine. One is a copy of XP corporate SP1 that was updated to SP2, and the other is a full version of XP, which was updated directly to SP2. (Both updates were done using the full network installer from Microsoft, not done with Windows Update). Both machines were current with all of the “Critical Updates” from Microsoft.

The machine I am typing from right now I was able to use system restore and get things back up and running. I went into CAV and disabled all updates at this point so that its still running fine, but just not the latest engine or defs. The other machine did not have restore running on the drive (not much HD spac) so I need to manually get rid of the clutter there.

I wasnt running anything while the update was running, the machine booted, and while I was doing other things waiting for boot (Its an older machine, so Im not used to speedy boots anyway) it downloaded the update and told me to reboot to complete it.

After the boot it was not actually locked, as you could move the mouse around and highlight icons on the desktop, but you could not open any programs or navigate to anything on the system.

So far it seems that something with this update is just not making machines happy.

Has anyone from Comodo been contacted about this? I havent sent a service ticket in, but I can if need be… I was sort of hoping they watched these forums as well…

Thanks again for the input. Hopefully this can be resolved soon, or will be with the 2.0 release. I just hope that its not going to turn into a resource hog…


~Bug: At least one person from Comodo tries to read every single post to the forum on a daily basis. However, for completeness’s sake, it may be best for you to submit a support ticket in pls. This will make it easier for us to track progress internally as well as diagnose more fully with you off-line, and then post results to the crew.

(I’ve also forwarded this post on to the dev team.)

I am getting the same problem. I get an auto update of the virus definitions and restart the computer as requested and login to windows. From there on out the computer runs extremely slowly. It is running but at a snails pace. I have restored back to before the update several times and the computer comes back to where it was normally but as soon as the virus definitions are updated and I restart I get back to a very very very slow computer. I have not restarted as of yet, and don’t plan to, but this seems to be a big problem.

Yes, Yes, Yes; Me too. This is exactly what is happening to me. As I thought I had found the solution yesterday, I went home and tried it all out - with the same outcome every time. Not to be repetitive here, but you should see the picture is the same -

WinXP Pro w/sp’s - older model 600mhz - installe ran fine - updated stopped running fine (lock-ups right after login screen - mouse moves, icons highlight but no worky).

So…, re-booted to safe mode, then MSConfig and turned off related entries in startup and services tabs - cool. I didn’t try to de-install from safe mode - I re-booted insted to normal, and re-installed over the original. Here I re-clicked to instal icon where the proggy uninstalled and rebooted, then I re-installed. Everything is perfect - until the Dreaded Update. Once the update completes, the lock-up circle starts again.

I am going to reinstall today with the June (i think, maybe July) Signature and not update it again until there is a fix -

Do you know, would this be soon?

Thanks a bunch!! Rossman

Thanks for letting us know Paulo. It seems to be a problem with only the last update, so hopefully the development team can figure things out and get a good fix.

Ill send in a support ticket a little bit later on tonight.

Until then, Ill just run the old definitions and hope for the best.