Computer does not get IP address from router when rebooting

Friends

I wonder what could be the reason for the following behaviour?

I have a TP-Link WR641G wireless router connected to an ADSL modem. I connect using PPPoE, and use a Toshiba Tecra running XP Pro on it. Now, lately, when I reboot my computer, then my computer does not get an IP address from the router (I use a wired connection). Even an Repair does not help. The only thing that works is that I turn the Comodo Firewall to Allow All, and then do a repair and only then I will get an IP address from the router. After that I can turn the Comodo to the Custom level and things works fine till next reboot.

So I suspect there is something that the Comodo is preventing that makes the IP adderss not be accepted by my computer. But I look at the log and there is nothing in it.

I have a home network zone in the Comodo. That covers the whole IP range, ie 192.168.1.1 to 255. The router is 192.168.1.1 and my personal computer 192.168.1.100. Is there something else that I need to allow so that the router and my computer talks to each other?

Grateful for suggesions
Calle2007

G’day calle2006 and welcome to the forums.

If this laptop is just for home use with occassional roaming usage and you’re using a wired connection, why not allocate a static IP to the wired connecton and leave the built in wifi set to DHCP, in case you go a-wandering.

If there could be a problem with your chosen address already being allocated, change the DHCP address allocation range in your router so it is only allocating .1 to .99, and then allocate .100 to your Tecra. This would mean you would always get .100 and it would never interfere with and DHCP allocated addresses.

IMHO, I’m starting to think that there can be an issue with DHCP address allocation lag caused by CFP, but this is an idea that is still germinating. It’s not consistent or necessarily repeatable, but there have been sufficient posts on this topic to start the wheels turning.

Hope this helps,
Ewen :slight_smile:

Thanks Panic

I think I solved the problem myself, after reading those other postings about not connecting to the Internet and the NIC.

I had installed several security related freeware lately and I uninstalled them all. Then I cleaned the Registry and finally checked what is started up at boot. I cleaned the ones I did not like.
The ones I cleaned out were:

Cyberhawk
ProcessGuard
SuperAntispyware

Now I seem to get my Internet connection back after a reboot. Not sure which one of the above was to blame, though.

Thanks
Calle2006

Ok, I thought I had solved the problem, but I got it again. (:AGY)

When I booted my machine this morning, the problem was back, ie only by allowing all in Comodo did I get an IP address from my router.

Well, I then went to the registry and sought for any of these programs:
Cyberhawk
Processguard
Superantispyware
Safezilla

I deleted lots of instances of those in the registry. Some of then I could not delete until I closed down Comodo. I had uninstalled all of those programs but obviously they leave a lot of junk behind in the registry.

Not sure which one of those causes the problem, but I don’t think that I will reinstall them to find out either. Or, if this problem occurs again then I believe it must be something else.

I wanted to write this update in case someone else has problems like this.

Calle2006

Hi again

panic wrote:

IMHO, I’m starting to think that there can be an issue with DHCP address allocation lag caused by CFP, but this is an idea that is still germinating. It’s not consistent or necessarily repeatable, but there have been sufficient posts on this topic to start the wheels turning.

Calle2006 writes:

I am also starting to think that the problem was not any of those programs I mentioned, but something in Comodo. I have deleted all those programs an cleaned the Registry etc and still I get that problem of my computer not getting the IP address from the Router. All other computers on my home network works just fine.

I use the latest free version, and it is possible that this problem started immediately after the last update of Comodo.

I can get by by doing the following:
Start the computer
Wait till it finishes boot
Put Comodo in Allow All
Do a Repair of my wired connection
Wait a short while and then I get the IP address from the router just fine.

But it is not the way I would like for it to work.

I looked at the Comodo Activity/Connections when I last time did the Repair. There were many things that happened at that Connections page immediately when it did the Repair. Unfortunately they don`t stay there so I cannot tell you what actually happens when it finally gets the desired connection. But it is clear that something is done then that makes the computer get an IP address from the router at that stage.

Any ideas what to try?

Thanks
Calle2006

Hey calle2006,

I think it’s time to lodge a support ticket with the official support centre (http://support.comodo.com). You’ll need to register first, and in addition to describing the problem, I’d add details on your router - brand, model, firmware revision etc.

I’ve tested on several routers and had no problems with Cisco (all models tested), Netgear (WGT624V3) and D.Link (forget the model number). I did, however have intermittent problems with a Dynalink router (I think the model number was WL320A). It may come down to being router related. ???

Let us know how you get on with this.

Cheers,
Ewen :slight_smile:

Hi panic and others

I think I found the problem. It was not a problem with Comodo, but it seems that I had deleted a necessary Network Control Rule, the TCP/UDP out rule. I looked at the default rules described elsewhere on this forum, and noticed that problem. Now, when I boot the computer I do get an IP address for my computer from the router.

Thanks again for your good help.

Calle2006

Glad to hear its working and even better that were able to rebuild the missing rule yourself.

Well done!

Cheers,
Ewen :slight_smile: