Computer boot slow and run slow

Hi, the machine is windows 2000 server. After installing comodo anti-virusspyware and rebooted the computer, it boots really really slow and runs really really slow. I couldnt do anything basically. so what i did is boot into safe mode and disable cavs from the services. after that, booting up is better and runs better. however, many windows components stopped working. for example, when i click on “add/remove program” nothing happens. or if i want to change network settings, there’s no network showing. anyone experience similar problem? any solutions? Please help.

Hi marc & welcome to the forums.

The same thing happened to me with CAVS The boot was so slow, that some windows components failed to start. The solution, for me, was to try CAVS 2 beta. Booting was still a bit slow. But, nothing like CAVS 1, nothing fails to start & CAVS calms down after a few minutes (CAVS 2 runs some initial scanning for trusted applications).

If you boot into Safe-Mode then Windows only starts the minimum core components. This does not include MS Installer (MSI) or Networking (unless you specified Safe-Mode with Networking prompt).

Since you can’t run MSI, it sounds like you’re still in Safe-Mode. Reboot into normal mode. If you cannot remove CAVS in normal mode, then you can use the SafeMSI utility to enable MSI in Safe-Mode. This is not an issue with CAVS 2, since Comodo stopped using MSI exactly because of this type of issue. If you are experiencing the slow-boot-of-death with CAVS 1, then boot into Safe-Mode, use the SafeMSI to start MSI & uninstall CAVS 1.

Or… have I got this all wrong & it is CAVS 2 beta that you installed?

Hi Kail, thanks for the reply!
The CAVS version I have should be 1.1 beta downloaded from the web site. Where can I download version 2 beta?
You are right, booting to safe-mode does not include ms installer, that’s why I can only disable it intead. I’ll try SafeMSI and report back. However, I did try the manual uninstallation posted at,887.0.html not sure if it’ll interfere with the normal uninstall. I guess I’ll find out soon.

I don’t think CAVS 1 has been in beta for some time. So, that’s probably the release version you have (unless it is an old version). The CAVS 2 beta has its own forum section CAVS BETA Corner and the download link is available on this topic. Since beta testing started 2 weeks ago, there has been a release a week. So, you’ll need to keep a close eye on the BETA Corner section for annoucments. Please note that this a beta & as such things can go wrong. So, you’ll need to comfortable with that. As I said, I found CAVS heavy on booting & especially the first boot with CAVS additional one-time scan process. You should also be aware that CAVS 2 beta has a HIPS (Host Intrusion Protection System) element. HIPS will, initially, produce lots of pop-up alerts until it learns what you are running.

Hi, I tried the SafeMSI in safe mode but it didnt work since my add/remove program can not be started. When I click it in control panel, nothing happens. I found this article on how to restore add/remove program applet at ITPro Today: IT News, How-Tos, Trends, Case Studies, Career Tips, More
it didnt work either. add/remove programs still not working. anyone got any ideas?
about the components that didnt work, I dont know what I did, after reboot, those components started working. so now the only problem is add/remove program not working and I can’t uninstall CAVS version 1.

I believe CAVS 1 has its own Uninstall shortcut under the Start menu - Programs. So, you don’t need to run the Add/Remove Programs applet. You only need to boot into Safe Mode, run SafeMSI (to start MSI) & then run the CAVS Uninstall. I don’t think the CAVS 2 beta uses MSI, so you will not need to worry about SafeMSI for CAVS again.

thanks for the reminder Kail. clicking on the uninstall thing didnt do anything either.
looks like uninstallation is an impossible thing at this point. i got into the registry and remove the entry in the “run” key to so that cavs will not try to run at start up of pc, the cavs service is already disabled and i also stop the launch pad from starting when logged on in the preference menu. i think i am just gonna leave at that for now…

Don’t forget the CAVS boot driver (cavasm.sys). This can be found in the DRIVERS directory, off the SYSTEM32 directory. In Safe Mode, you can simply rename the file to disable it (eg. cavasm.sys → cavasm.DISABLED.sys).

If you want to resolve the problem in the future, check the Windows event logs. Since CAVS 1 uses MSI, there should be an entry in th event logs when the CAVS Uninstall shortcut is run.