Completely disable the Defense+ ??


i use the newest Comodo Firewall version and unchecked all options relating to HIPS but unfortunately it still blocks a tool which i need. :frowning:

Have you any idea? Many thanks ahead!

Kind regards

Hi Ur7urn,
Do you get any alerts when it is being blocked?
Do you get any event logs to show what module is taking action to cause it to be blocked?



no i get no messages because I only use the Comodo firewall. The tool makes a change in a system path but if Comodo is running, it protects it I think and even hides system processes which the tool must find. So the tool dont work cause it doesnt find a determined ssytem process. :frowning:

Im sure the problem caused by Comodo’s Defense+, or?? I always have to remove the Comodo install path in the registry to fully deactivate Comodo functions so that the tool works.

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\Software\Comodo\Firewall Pro\Configurations]

In older Version (CIS 5 I think) u could diable Defense+ completely look here (sorry german Version)

I can translate: “Defense+ permanent deactivate (require a restart)” but where is it in the new Comodo Version??

Many thanks ahead for support!

Kind regards

Hi Ur7urn,
Sorry I am not sure how to help, let us hope someone else has some ideas.

Note: For use with 100% trusted files only.
You could try adding the tool/file to the Behaviour Blocker exclusions list.
Define exclusions for behavior blocking-Comodo Help

Note: Later versions of CIS do not have the option/setting to disable ‘Defense+ Permanently’ like previous versions.

Kind regards.

thx captainsticks for the hint

the point was ‘Detect shellcode injections’ which I searched for. Ive also found it on similar link Behaviour Blocker, Network Access, Internet Protection | Internet Security v6.3

Best regards

You are welcome. :-TU