Complete scan fails to finish


I’ve tried to do a complete scan several times now, btu it just fails to finish. All files get scanned, it just never winds up and completes. 9 hours is the longest I’ve waited for completion.

Am I just being impatient?

CAVSN.EXE is runing at 90%-99% when it gets to this “hung” state. Hung isn’t the right word, as the application is still responsive and can be stopped manually.
individual drive scanning, folder scanning and file scanning isOK - its only the complete scan. I thought that it may hav been the last item scanned that was causing the issue, but that individual file can be scanned on its own without a problem.

any thoughts?
ewen :slight_smile:

i’m almost having the same problem… except that in the logs i get scan terminated, with 0 files scanned. happens all the time. e-mailed support asking me to try doing a scan in safe mode, and i still get the same results. still waiting to hear a response back from them… its been a few days already.

anybody else having issues doing a complete scan?

tr1xter47: I’m having the same problem as you. I start it, go do something else and after an hour or three, it just stops the scan and the window closes. When I check the log, the same thing as the one you got is shown.

Could you Pl list out the name of process running while scanning is going on? scanner detects any virus before it closes/stucks?

no viruses are found before it quits…

Same problem here. No viruses found during the scan. On mine computer tha scan stucks at a folder that has many and large compressed files

Same here - folder with large quantity of files,including large archive files. No errors, no warning, no end. :frowning:

is there any specific file it gets stuck on?

It appears to have a problem with ZIP or 7zip files over about 10mb in size with more than 1000 files in the archive.

I’ll see if I can pin it down definitively.

ewen :slight_smile:

it would be great if you can Ewen… it would help us a lot in identifying a fix for it asap.

thanks for the great help.



The problem, I think, is in the number of files inside the archive. I had a 11.5 mb zip file with more than 2000 files in it and the scan wouldn’t complete. I removed this file and replaced it with a 12mb zip that had three files in it. The scan completed, possibly ruling archive file size out as an issue.

did you want me to dig further?

hope this helps
ewen :slight_smile:

Could you pl decompress “11.5 mb zip file with more than 2000 files” and scan the decompressed files. Does scanner works fine?

The unpacked files are scanned correctly.

Sorry, I should have added that to my previous post. :cry:

ewen :slight_smile:

P.S. CAV doesn’t recognise “spyfalcon” and its associated trojans. Mongrel to get rid of and is usally bundled with smitfraud.g

np :). Thanks. Developers are checking it.

Keep submitting the samples if possible with some description.

Hi, Could you reinstall CAV and check again?

I think I found the root cause.

Imagine you had a zip file called “Z.ZIP” and it contained numerous files including one called “Q.ZIP”. Now imagine if “Q.ZIP” contained a file called “Z.ZIP”…

There is some sort of recursive voodoo going on. As soon as I removed the Z.ZIP file from within the Q.ZIP file, all was well.

AhnLabs and AVG don’t like this recursiveness and Nortons went into Orangutang mode (hopped onto its back legs, waved its arms in the air, screamed at a banana and achieved little else!). It then promptly vanished up its own fundamental and BSOD’d. LOL! Best place for it I’d say! LOL

Hope this helps and I promise to do my best not to inflict dumage (damage caused by an idiot) on the forums again. Until next time.

Thanks all,
Ewen :slight_smile:

oh dear…
so other AV products don’t like this either? Did you test it? Can you pls submit that file to us.

thanks a lot Ewen… good piece of detective work there Holmes :wink:


I am having the same issues… I can’t locate where it stops. The window just disapears and the log says “terminated”. It is somewhere in mydocuments application data. I think. I have uninstalled and reinstalled and the same thing happens. Any additional help on this would be appriciated.

The auto terrmination of CAV bug is fixed in updates Get latest updates and scan your system.