Complete Internet Blockage

So I installed CIS. I’m using a laptop on a wireless network. My home network was fine but when I went to school I couldn’t connect to the school network. I tried diagnosing the problem and it said there was something wrong with the DNS server. A classmate told me that got the same problem when they installed a new antivirus. I tried turning comodo off, no connection, uninstall comodo, no connection. Went home, got on my home network fine. Downloaded and reinstalled comodo but this time I told it to not use the comodo DNS servers. Installed and restarted, poof no internet connection. I’ve tried uninstalling comodo, no good, used a restore point to before comodo was installed. It tells me there’s something wrong with my network adapter. I cycled my modem and router, no help. The other computer, my phone, xbox, ps3 can all connect to the network just fine. So…what do I do now?

Start with running this clean up tool in Windows Safe Mode to be sure CIS gets uninstalled completely.

In case you still you can’t connect to the web. Then the Inspect driver is still present and needs to be uninstalled.

How to uninstall the CIS firewall driver when it stays present? Look up the properties of the network connection, select the Comodo Firewall driver and uninstall it. See the attached image.

When done reboot and CIS should be gone.

For the situation on your school network make sure to disable Block fragmented IP Datagrams. That setting is known to create problems on bigger LANs like University or corporate LANs. It will be disabled by default in v5.8 because it causes too much problems.

Sometimes left overs of previously installed security programs are in the way. Please make sure none of them are no longer present.

Try using removal tools for those programs to remove possible traces. Here is a list of removal tools for common av programs: ESET Knowledgebase .

Also read No network connection after using Stealth Ports Wizard (DHCP Broken) for further reference.