Comodos newest update stole my vista permissions!


■■■■■■! i had to take ownership of my own system after this last update! TrustedInstaller is the name of the “profile” created by the update that stole all my systems permissions. It took the permission to even reboot from me! TrustedInstaller my @ss!

Nevermind, setting permissions didn’t do anything! So Now I am stuck in safe mode, and for once have no idea where to go with this problem… WTF did Comodo’s update do to me?

Can you please clearly tell us what the problem is? TrustedInstaller.exe is a trusted component of Windows Vista Updates…


The problem happened because I was doing my classwork (University of Phoenix), and then Comodo popped up saying an update was available. I clicked ok figuring sure what the hell, and let it do its thing in the background. Then it asked to reboot, but because I was busy I made it wait. Then I had to feed my son, and forgot about restarting but instead put the computer to sleep by closing the lid (laptop). Then I log back in, and continue my school work, but then proceed to try to open another program and “access denied, you do not have permissions to access or view this program” and something about the shortcut being deleted. Me forgetting at first that comodo updated said “WTF!!! I didn’t even do anything!!!” Then I proceeded to get even more angry because I don’t have the time to “troubleshoot” when I have school work to do, and kids to watch. So I just go right to the root of c:\ right click it and go to the advanced security tab and set the permissions for the Administrators group to have full control over everything, and click apply. Of course I get the expected hiberfile.sys error, and pagefile.sys error. But hey those are controlled by NT_LOCAL_AUTHORITY anyway right? So thinking it’s going to be ok but still being rightfully paranoid I reboot into safe mode. Once there I look around, and notice comodo at a different version number while I was looking through change logs of VSC…Volume shadow copy, and then uninstalled it and rebooted. Finally the system works now. Although I am thinking that I should reset my permissions to default but I forgot how…■■■■.

Ok as far as I see, you did not restart normally, but thinking something could be wrong, restarted in safe mode and tried to uninstall.

That was not necessary. If you restart your PC after the updates(not necessarily immediately but later), the updated version is going to handle everything for you.

Changing default permissions on your Vista, dealing with hibernation page file or pagefie.sys access rights, will just give you more trouble. Things are not that much complicated. A simple restart is what you need 99% of the time.