Comodos last block rules started disabling everything? (also warcraft host prob)

Hi all! Got a problem with comodo firewall.

Me and my friend could play warcraft 3 in lan with 2 computers (at my house) when i configured comodo (couldn’t if it was unconfigured so making rule helps). This day it didn’t work in BNet (I just got out of my ipbans and we went BNet playing (Friend not at my house this time)).

I tried adding rules and changing them and even making the last network rule to “allow”. Still didn’t work. I dont have router with firewall because uTorrent says it can connect correctly (I have configured it to be allowed). After a while I configured some stuff I noticed internet didn’t work. Only uTorrent I had enabled! I was like “Oh, my Lord God Almighty! [!]!”. I tried some stuff fast and last tried enabling everything from the last rule and then everything worked properly.

Could someone tell what I did wrong so that internet suddenly stopped working after I changed some OWN MADE rules.

I want to use internet so that I dont have to allow every connection connecting to me, don’t want to keep last rule allowed.

Maybe I deleted accidently one rule that allowed “normal” internet acces?
I have to keep last rule “Allowed” now to make everything work. Allso uTorrent works if everything is blocked because I have own rule for it in the list. So I believe I deleted accidently some critical rule. Does anyone know if there is some important rules I have to have?

Now I got there something like this. Check the picture in the link.ön.PNG

I highlighted 3 my own made to make warcraft 3, uTorrent and LAN file and printer sharings work. Other rules been there allways. As you see I have allowed the last rule so I can use internet.

Thanks allready!
(Comodo’s Firewall had allways worked nice and well. Even portforwarding was succesful!)
Comod 4ever (R)

EDIT: Adding one log info example when I had last rule blocking like it should be. I was spammed by similar messages like this:

Description: Outbound Policy Violation (Acces Denied, IP =, Port = dns(53))
Protocol: UDP Outgoing
Reason: Network Control Rule ID = 7

Edit: Hosting problem with wc3 solved… We got new router that I didn’t know about. Routed it