Comodo won't let me use Xfire (PICTURES INCLUDED)

Hi. First, let me just say I love Comodo. It’s just that I have a few problems that can hopefully be resolved today.

I just recently downloaded a program called Xfire. Long story short, it’s basically a way to play MMO games with many people. Once I downloaded it though and it tried to let it connect to the internet, this poped up:

Now, I see this all the time so, I chose to go the show libraries tab.

I choose to alow it because I know what it is and trust it. I also choose “remember” allow for the first picture. Everything should be fine now right?

…Unfortunately no :’(

Even though I told it to remember both of then, it continues to ask me over and over again, usually seconds apart the same question. It won’t remeber that I told it the Xfire tucan dll was ok and that Xfire.exe can connect to the internet whenever it needs to. This keeps me from being able to play MMO games. Everytime the game goes into full screen, it freezes because comodo won’t let CLI.exe, Xfire.exe or Xfire Tucan.dll connect to the internet on it’s own. I’m not sure how to handle this. I only solution I could think of was to disable my firewall while playing online, but that really unsafe.

Any help is much appreciated!

I just realized that there is a version 3 of Comodo firewall. Should I maybe try version 3 first? I won’t switch to version 3 unless you guys feel it will help solve my problem (or it’s just recommended to upgrade to v3)

In CFP v.2.4, it looks like you’ve got loopback (IP address turned off.

Click Security → Advanced, Miscellaneous → Configure. The mark the checkboxes for Skip Loopback for UDP and for TCP.

Thank you so much! So far, everything seems to be working ok now. It’s a major thing to me! (S)

So, Now that I know there is a version 3, should I go ahead and upgrade?

Glad to be of help, and that things are working for you now.

Updating to v3 is really up to you. It still have a few sharp edges, that are being worked out in the “Help for v3” forum. You can eyeball the posts there to get a sense of things.