Comodo with UT/Unreal Tournament (Classic aka 99)

For clearity:

I’m running CPF
I’m trying to get the server browser working in UT.
I run Vista x64.

When I enter UT99 it’s all fine, no questionboxes or anything, if I manually enter an external IP to play on, then I can enter that server, with no problems what so ever.

Thing is, if I look in the server browser, all the servers give me ping 9999, which means they can’t be found. If I click on a server which can’t be found, and keep it selected for about 5 to 10 seconds, it will show the normal IP and server info.

Is there a way to make the serverbrowser work normally again?


Edit: even when I turn everything off/disable Firewall and Defense +, or change it to whatever setting possible, it doesn’t change, it still does the same thing. The only way that I’ve discovered to get the serverbrowser back to normal is actually deinstalling Comodo, just turning it off doesn’t work.

Hey Apollyon,

Try adding UT as “Trusted” in:
Firewall\Advanced\Network Security Policy
Defense+\Advanced\Computer Security Policy

Find the exe & files or see if they are in there. Make sure nothing is blocked…


All games work with Comodo. Read my thread.

Thx for the quick replies, appreciate them :slight_smile:

First reply: I already added the game to both policy lists as trusted, that didn’t do it, so that doesn’t work/that’s not the problem I guess.

As to the second, I now tried playing it for 5 mins, manually selecting every server till it showed, and that didn’t solve it either. It just shows them at that time, till I press ‘refresh’, and they’re all ‘offline’ again.

Thing is, the game itself working, the server browser in the game is not, and it’s kinda hard to see which servers have people, which have not, which are decent, etc, without the server browser.

To sum up: I can play, I can manually select servers, BUT, and that’s a decent but, I can only select a server from the serverbrowser if I keep a server (which he says is offline) selected for about 5 seconds, and I have to do that for every single server if I want to see them all.

If it’s not clear what the problem is, I can always post a screenie of the problem if that might help/give you a better idea of what’s going on, instead of me trying to explain it with my crude and perhaps unclear sentences. (But: servers showing offline and with 999 ping, which means offline, till you manually select it and keep it selected for at least 5 seconds).

Tried every setting in the program, and the serverbrowser still only works normally when I de-installed comodo, which I don’t want :confused:

Anybody a clue/had the same issue with another game orso?

I play Unreal with no troubles. Are you using Gamespy servers? Does your logs say anything. Have you tried deleting all entries of Unreal in D+ and the Firewall then reboot. Put D+ and the Firewall in training mode and play the game. Works for me in ALL games.

Did you make an application rule ? Mine for UT is allow any ip on any port

Again, thx for the responces :Beer

Tried your suggestion Vettetech, kinda did that yesterday already according your thread (great thread btw, think you helped alot of people with that), didn’t reboot then though, did now… still didn’t change anything, still no normal working serverbrowser. For the rest the game works normal, it’s just annoying without the serverbrowser…

My servers are:

ServerActors=IpServer.UdpServerUplink MasterServerPort=27900
ServerActors=IpServer.UdpServerUplink MasterServerPort=27900
ServerActors=IpServer.UdpServerUplink MasterServerPort=27900

I’ve tried adding them to trusted, and I’ve tried them one at a time, so deleting the other two, it all doens’t work.

Problem is, the UT99 serverbrowser doesn’t even work when I turn the firewall OFF/disabled, not even when I press on the icon and use “exit”, the only way to get it to work is uninstalling CFP, and yes, then it does work flawlessly, so it must have something to do with the firewall :confused:

I’ve tried making the application rule manually in both, I’ve tried letting it add it by itself (training mode and normal mode) and I’ve tried making it a trusted application, also ofc in both, nothing works to make the serverbrowser work normally.

Two question:

  • Does one of you also run Vista x64? Might be an issue with Comodo, UT and Vista64?
  • Do you still play UT? If so, care to share your nicks? :wink:


I am on XP Home but I play UT2004 on my pc. I play UT3 on my 360. Two things to look at. Do your logs say anything that might lead to the problem? If my memory serves me well UT uses Gamespy servers and Punkbusters. Are both those trusted under the firewall and D+? There is Punkbusters A & B.

UT99 doesn’t have punkbuster, nor does it use gamespy, it just uses a masterserver (for example the epic and/or gamespy one), and I’ve added both of those to both policy lists as trusted. The log shows absolutely nothing regarding blocking anything, it allows UT, it says it blocks nothing.

As I said, I can play, the serverbrowser is the problem, the rest works normally. What I don’t get is why it also doesn’t work when setting the firewall as disabled… and why it does work when I uninstalled Comodo. Doesn’t that show that it’s not a settings problem regarding allowing things, or not?

Perhaps the firewall kernel is blocking/adjusting my network traffic even when I disable the firewall/D+?

When you exit Comodo via the taskbar icon that only shuts down cfp.exe which is the GUI. cmdagent still runs and cannot be shut down. There are 2 processes belonging to Comodo. Most security software is like this.

Yeah, figured as much, was hoping this might give me an explanation as to how/why it’s not working.

But shouldn’t cmdagent also be disabled when turning the firewall and D+ to disabled? Or well, it ofc protects CFP itself, and some key elements, but disabled should unblock everything, right? So I don’t really see how it’s possible for Comodo to still make a difference to a game when everything is turned off/disabled/trusted…

Just tried disabling the cmdagent as a service, that also solves the browser issue. So something in cmdagent is blocking the UT serverbrowser, and only the UT server browser…

I’m truelly baffled at this moment ???

Ahwell, guess Comodo just isn’t compatible with UT99

I am sure it is. Have you check the UT web site. BTW why are you playing a such an old game anyways? Is your game fully patched and up to date?

Look here.

Yeah, solved that problem when it happened :slight_smile:

Thing is, it worked perfectly untill I installed Comodo, and it still works perfectly when I uninstall it, or when I disable the cmdagent service. Settings don’t change anything, and I can disable the Firwall/D+ and it still changes nothing. Only making sure cmdagent isn’t running fixes it.

So basically: if cmdagent is running, it won’t show the serverbrowser normally, no matter the settings.

It could be a combination of CFP and Vista 64, but I know for a fact it doesn’t work. If you don’t believe me, I could send you a copy of the game if you want, seeing it’s free to distribute now anyway. Installing takes about 30 seconds max, and you’ll see it doesn’t work.

And as to why I still play, hehe, been asked that alot, alot of people actually still play it, and it’s still considered the best of the UT games. UT99 still has alot more players than UT3, for comparison.

LOL…that’s not the same problem. And if you look closer…what date is that from? Oh and the year…2004.
The problem is that it is terrible slow to browse Favourites and/or the Master Server list. But it works.

The problem persist even without Comodo installed…the problem got something to do with ÚT 99 and Vista x64. UT 99 works perfect under Vista x86, XP x86/x64 and Win2k3 x86/x64.
Frankly…the best OS for UT 99 is linux (:CLP)

I’ve looked for a solution to this problem a long time…and yeah, I really like this game (:LOV)
If someone could help us (old school idiots) to solve this issue with UT99 and Vista x64…

Post it in the Unreal site then. Best place for help since you say its not a Comodo problem.

It is Vettetech, UT99 works perfectly for me when Comodo isn’t installed. Even the serverbrowser works like a charm then.

Like I said, if I deinstall it, or disable the server, it all works great, it’s a Comodo problem, I’d be happy to show you some screenies if you’d like, to prove it’s Comodo related. Hell, I’ll even make a movie if you prefer, showing how’s it’s not working when Comodo is on, and how it works when I disable the service/deinstall it.

Or you could just take my word for it, Comodo is a great program, no doubt about that, it’s just not compatible with UT99.

@ gmork, do you still play UT99? Got a nick I might know?

Ahwell, seems there won’t be a solution to the UT/Vista x64 problem. So now I’ll either dual boot, or just delete it and be done with it guess :confused: