Comodo will not let Windows Defender update.

Stats –
Win2K3 Server
Comodo ver
Defender ver 1.1.1593.0
Have seen earlier posts in which this problem was noticed and the ostensible solution was to update to the latest version of Comodo which at that time was Beta. I have checked my NM rules and nothing seems out of line. AM rules were a possible issue in that Defender was not in the App Control list. Attempted to scan for known apps and the scan did not find Defender (?). Manually added it to the list and no effect, still could not update. Turned off Comodo and the update works exactly as it should. I guess the question is: What rules do you have to have in place for Comodo to allow Defender to auto-update, i.e., Net and App control rules? Thanks.

Welcome to the forums! (:WAV)

I don’t know specifically, since I don’t use Defender any more; haven’t for some time now. However, most apps have a different update executable that will need to be in the AppMonitor. You might dig into the Defender file to see if you can find the update module, and add that .exe, with the parent to “Learn.”

If you can’t locate that, or if that doesn’t work, do this:

Security/Advanced/Miscellaneous. Uncheck box, “Do not show alerts for applications certified by Comodo.” Move Alert Frequency slider to High or Very High. Click OK. Reboot computer.

this will create a lot of alerts for you, but you can turn it back down later. You will need to allow the svchost.exe alerts (if you see them); the system needs it to communicate. You also may see an alert that your browser is trying to act as a server. You will need to allow that, too; it’s internal communication only, not a security risk.

Then open Defender, run the updater. When you get a popup, check the “Remember” box and click Allow.

Once you make sure it’s working, you can turn down your alert frequency stuff, and skip the alerts for Comodo-certified apps. OK. Reboot.

Hope that helps.