Comodo will never remember decisions

I’m sure Comodo will not consider it a bug, but this program is getting beyond a joke with regards to its CONSTANT prompts for decisions, despite a decision having been made a HUNDRED times already with the ‘remember my decision’ box ticked.

Numerous people seem to have posted on this with the essential suggestions/answers being to go to great lengths to change permissions/settings. This is, frankly, ridiculous. If it asks for a decision, and asks if you want it to remember, it should do that.

Otherwise, what’s the point? I mean really?

I just had to give repeated permission, over TWENTY times, for the same application to run. No registry changes, none of that nonsense, just for a bit of software to run. HP health check, should you be interested.

Does anyone know of a good firewall that CAN actually remember when it offers the option?

I totally agree with you. They should look into this.


Is this program on an internal hard drive or on an external type of medium? What alerts do you get? Please post a screenshot of the Defense + logs (View Defense+ Events).

What happens when you add it Trusted Files?

I have the exact same problem when I try to run SlimDrivers or SlimCleaner from slimWareUtilities. No matter how many times I click the D+ pop up and tell it to remember my choice to consider it safe, I get the same freekin’ pop ups every single time. I even tried to manually add it, but it just doesn’t remember my answer…Very disappointing is a massive understatement.

D Bone. Does the program run in the sandbox? Does this program make new executable each time it gets started? If that is the case give the executable the Installer/Updater policy.

Hey Eric, no, they do not run in the sandbox. Also, neither program makes a new executable at start up.

Slimware Utilities is on the TVL.

Having just installed both SlimDrivers and SlimCleaner, apart from the initial prompt during installation, no additional alerts were received during operation.

What are your settings for D+?

What mode are you running? I just downloaded both SlimDrivers and SlimCleaner. Not a peep from D+ in Safe Mode.

The same thing happens with blender. I added blender to trusted files but I’m still getting a prompt by comodo and I think it’s because blender has not been digitally signed. Regardless I should still be able to run blender without approving it first because the program is on my trusted files list.

I submitted blender to be whitelisted in the stickied thread so this will not be a problem anymore. Hopefully a strange incident like this won’t happen again.

D+ was in safe mode. I uninstalled CFW on my test machine because of this, maybe I’ll try the new version sometime today. The machine is XP x32 SP3.

I have just started having this problem myself. I installed a new media player (in lieu of WMP). No matter what I do, I receive a Defense+ popup alert every time I either open the player or go to open a file. I have added it to the trusted files, tried to run it in the sandbox, with the same result.

Can you show a screenshot of the D+ logs (View Defense + Events)? That may help us to better understand what is going on,

I have attached a screenshot.

It seems the video player file is being blocked by windows explorer.

[attachment deleted by admin]

I have seen this issue a few times with Firefox’s plugin-container.exe repeatedly asking me to launch RealUpgrade.exe even after I’ve chosen to allow & rememeber.

The entry is added multiple times to the allow list, yet it continued to ask me to add it again.
See the attached images.

(Note: The multiple entries were added by selecting “remember” through the prompt - not added manually.)

It stopped asking at some point.
Perhaps after a reboot?
Just a guess… I really don’t recall.

[attachment deleted by admin]

Can you see if it is in Blocked Files (under Computer Security Policy)?

Yes, it was there. I deleted it, looked and saw it is still under trusted files. Tried to launch with the same result.

It seems I’ve had to change my Defense+ setting from “Safe Mode” to “Clean PC” mode in order to get it to stop.