Comodo v4 messes up Windows Live Messenger windows

I’m using Comodo Firewall 4.0.138377.779 x64 on Windows 7 x64 Ultimate. When I install Comodo it messes up my Windows Live Messenger windows.

When Comodo is not installed WL has only one taskbar window, displays tray icon and when minimized to tray the taskbar window dissappears, as it should be:

When Comodo is installed WL has two taskbar windows, displays no tray icon and when minimized only one of the taskbar windows dissappears the other stays on the taskbar:

I use Comodo as firewall only. Defense+ and Sandbox is disabled. I even added WL exe to Defense+ with “Move to my secured files” option.

WL exe uses compatibility mode to make it display tray icon. Removing compatibility option didn’t make any difference.

I didn’t have this problem when I was using Comodo v3 x32 on this same system.

What should I do to fix this? I find this very annoying and thinking even to go back v3. I hope anyone can help me.

I also see this on both my Machines, However had no idea it was related to CIS…

I uninstalled and reinstalled several times to be sure and yes CIS is the culprit. I’m assuming it has something to do with Sandboxing since I don’t have any problems with v3 but I couldn’t solve it. Selecting “Do not sandbox this application” didn’t help either…

Any ideas about how to get rid of this problem? :frowning:

No ideas come to mind… sorry…

Moving to Bug Board…

Same problem here:

Windows 7 Ultimate 64-bit

With Comodo Firewall since v4 (currently have 4.0.138377.779) Windows live messenger does not seem to use the Vista SP2 compatibility mode which helps me save some taskbar space.

I had no problems with v3

Also running: Nod32 4.0.474.0

I have a ‘messing up screen’ problem that seemed to involve an interaction between CIS 4 and Trusteer Rapport (Banking security prog). Disabling Rapport fixes it.

Probably not related but I thought I would mention. Could you guys add full documentation of system details as requested for Bug reports? Important if you want this fixed.

Best wishes


Already, posted about this bug, but since this thread seems to be newer and even with the new version 4.0.138377.779 et Messenger v. 14.0.8089.726.

As soon as I reinstalled comodo 4 (since there was an upgrade) this bug reappeared.

Windows 7 64-bits
CIS Free 3.14.130099.587
Virus database : 3822
Firewall = SAFE MODE
Defense + = SAFE MODE SLOW BOOT Windows 7 x64 - when AV is DISABLED

That is weird, I’m not having that problems with WL.
Win7 x86 Ultimate is OS and latest CIS v4

I have the same exact problem!!! It also does this to skype.

At first, I thought it was me, but it is comodo v4!

Win7 x64 ultimate
av off
firewall safe mode
sandbox enabled (but all app are not sandboxed), I let it enabled just to be able to right click and run an app in sandbox
defense + safe mode

I posted about this back on March 4th.

I have a solution.

If you select the “Run a Program in the Sandbox” option for a “run once” action (run as “Unrestricted”), Windows Live Messenger compatibility settings are correctly honoured.
If you make a permanent rule though, they’re not. (What the hell? This is a serious inconsistency bug.)

If you permanently disable Defense+ (by checking the box that says so), and reboot, WLM will work correctly without further aid. You will, however, lose Defense+ AND Sandbox.
ANY OTHER combination of settings will fail. No exceptions. As long as Defense+ is not “permanently disabled”, it keeps poking its nose into the business of executables for no reason, even if Sandbox, Defense+, or BOTH are “Disabled” on the slider. It doesn’t matter. The code is still alive no matter where you put the sliders, and it knocks over the messenger program.

My suggestion:

  • For pity’s sake, include an option in the setup to SKIP installing the Sandbox component. I believe that code is the source of these issues.

  • Alternatively, fix the component - clearly, the “run once” command works, but rule creation doesn’t, as evidenced by WLM’s behaviour.

  • Why is the compatibility setting the business of Sandbox anyway? It should leave the properties of my programs alone.

I hope I helped. If you have problems with WLM, then reinstall an older version of Comodo, or disable Defense+ permanently until an update is available.

Ok given this I’m going to make an inspired guess that its guard32.dll that is involved. Can someone test please?

Just rename guard32 (in Windows\system32 and the comodo repair directory) then reboot. THen try running outside the sandbox.

If so the devs may be able to fix these compat bugs and several game bugs with one fix.



I am running windows 7 64 Bit.

I have set the sandbox level to disabled and I have set the Defense plus level to disabled.
This does not fix the problem.

What I have noticed is this.
If I turn on windows user account control, the problem is fixed (even without disabling anything).

But when I turn user account control off, something happens with comodo that it stops messneger running in the compatibility mode when user account control is off.

When user account control is enabled (and you have to click yes to start messenger, it works ok).

There is certainly a bug in the product here, because even if you turn everything off in Comodo (all levels) and have the program closed down, messenger still doesn’t run in compatibility mode when UAC is turned off.

It seems the only way to stop COMODO interfering is to uninstall it., or to turn on UAC (which is very annoying)

Can anyone else confirm this behaviour? That when you turn UAC on it works, but if you disable UAC, COMODO is somehow messing with something it shouldn’t be?

I have no idea what’s up with your computer, but I can’t confirm it. I can confirm my method of checking “Disable Defense+ permanently” though. You should try that and leave UAC alone.

I really think there is a good chance that this fix here will resolve the problem.

Worth trying, of only to inform the devs?

Best wishes


I have exactly same problem. Windows 7 Ultimate x64.

Windows live messenger 2009 icon is gone after installing Comodo Internet security, reboot and running msnmsgr.exe normal (not in sandbox) and I show two taskbar boxes. Stupid thing - I hade tring many solution (install messenger to another computer and paste windows live folder to here, disabling comodo before reboot after comodo install and more), but nothing work.

I use messenger Windows Vista compatibilty mode (tried XP, Vista sp1 and sp2 too).

PLEASE, this problem should be fixed!!! :frowning: If i must choose between comodo and messenger, I choose messenger, but I want use both without problem. :frowning:

I don’t want disable comodo component (guard64.dll), only want add trusted area for notification area. :frowning:

I wonder if you could tell me whether this is resolved in 4.1?

Many thanks


Yep, the issue has been resolved. Working on Win 7 64-bit, Vista SP2 compatibility.

This is great news. This was the main reason I was staying at 3.14. I’ll just wait for another day or so to see if others report it being fixed as well and then I’ll upgrade myself. :slight_smile:

Thanks for the prompt feedback. Will update the mods bug list.

Best wishes