Comodo v3 Blocking [Win32]Vista DellPersona Fingerprint Reader

Background Info.
I recently bought a Dell Studio 15 laptop. It comes with Microsoft Vista Home Premium.

Problem:
My problem is regarding Comodo Firewall (most likely defense section) blocking my computer from recognizing the drivers/required files for DellPersona Fingerprint reader during boot-up. It stopped functioning until after I installed Comodo Firewall. From my observations, the problem begins at boot-up time as background Windows Services are being booted-up during the login screen phase. The OS attempts to execute the fingerprint reader drivers/required files to have it listening for fingerprint scan requests, but it ends up failing and saying that it could not find the drivers for it even though ‘they are installed’.

My Troubleshooting Attempts:
I tried to troubleshoot it by placing the files in Defense> Common Tasks> My Own Safe Files but still nothing.

My Thoughts At Root of Problem:
My thoughts are that Comodo Defense is blocking the drivers for the DellPersona (made by Authentec Inc.) from even starting up during ‘Startup Services’ time.

  1. Anyone have any tips on how to trouble shoot such a problem?

  2. Is there a way to automatically group a whole folder to add in the Defense> Advanced Settings> Computer Policy? I’d really want to avoid having to go one by one registering ALL the files for both exe’s.

Have you tried putting D+ in training mode and then rebooting?
It should act like allow all and remember, so if it works remember to put it back in Safe mode or the like.

Later

I took Bad Frogger’s advice and I also put the associated files in question, C:\Program Files\DigitalPersona, C:\Program Files\Fingerprint Sensor, and system32\AFFSClientLib.DLL in a group all treated to work as Windows System Applications and it has still not functioned.

I have also re-installed the drivers for the fingerprint scanner as advised in another similar thread in the Comodo forums, but that method as also failed.

I still believe the problem lies in Comodo Firewall preventing the Dell Fingerprint Service from ever starting. Any clues as to how to make Comodo recognize that DellPersonal and Authentec Inc. are legit services?

Sorry was worth a shot, do you see any blocks in D+ logs?

Have you confirmed by disabling D+ or the firewall to see which one is causing the block?
See if it loads properly once D+ is disabled.

Yes, I’ve disabled D+ and the OS was able to launch the drivers to get the built in fingerprint reader to work. As soon as I re-enabled and rebooted again, it didn’t launch/find the drivers during boot up. And there wasn’t anything in the defense logs either.

There is a check box in D+ Settings > General Settings.
Block unknown requests if the application is closed.
Is yours checked?
If it is uncheck it and try it.

I believe that those hardware drivers are loading before CIS loads.
So if the check box thing doesn’t sort it out post back and we can look into a startup delayer.

Later