Comodo uses to much system resources

Hello.

  1. Pentium 4 HT 3.2Ghz, 32-bit
  2. Windows Vista Ultimate Service Pack 2, v.275 (6.0.6002)
  3. Also using Eset NOD32 Antivirus 3.0.684.0
  4. When using CPF 3.8.64263.468 combined with utorrent/emule or even none, Comodo somehow don’t let my CPU idle like it should.

When observating Process Explorer I can see that the process “DPCs” - Deferred Procedure Calls have and high load. When Comodo is uninstalled or with comodo 3.5 there is no problem.

I also have an request: simple configuration to block NetBios/etc from the internet but not for the intranet :-p

Anyway… :comodorocks:

Did you try a clean install of 3.8?

yes

Welcome to the forum luminoso :slight_smile:

Pls don’t hold me to it, but if this is about cpu usage, it’s going to be fixed very very soon, provided that we’re talking about the same problem that I know Comodo are aware of.

Thank you

this problem is not fixed on version 3.8.64739.471

I dont have this problem… So it might not be CIS all alone, that make this happen…

CIS is using ~5mb ram, and 0% cpu… Thats pretty good if you ask me…

You don’t having it doesn’t mean that it isn’t there.
I have searval reasons do suspect from comodo:

a) Only happens on 3.8.x versions
b) DO NOT happen on 3.5 version
c) Only happens when comodo is installed

This was the only recent bug report I found that specifically mentioned DPCs, but I think this issue might also be discussed in other threads.

After updating CIS to the newest version 3.8.65951.477 I’ve experienced a high DPC load that gets worse over time. Say a consistent load of 50kB/s up / 50kB/s down will, in a few hours, cause enough DPCs to start affecting audio and video playback. In some 12+ hours my whole system is extremely laggy and practically unusable, a reboot will solve the problem until the DPCs gradually pile up again.

I have no idea of the innerworkings of CIS but I managed to track the problem a bit with Process Explorer and xperf, and it looks like ndis.sys is what is getting hammered with DPCs. One might think this is a network card incompatibility, but CIS worked fine before the update and I also tried various drivers for the NIC with no success. I also pretty much closed every third party software or service running to make sure there weren’t any conflicting software.

I use http://www.thesycon.de/deu/latency_check.shtml to see the DPC latency of my system (in addition to process explorer and xperf). With CIS uninstalled the latency stays easily under or around 0.1ms (100 in dpclat) with network activity. With CIS installed it keeps increasing with network activity and reaches 10ms (10000 in dpclat) in half a day of consistent network load. Exiting CIS does nothing, only uninstalling it or disabling the network card/unplugging cable works.
If you keep the DPC latency checker open when uninstalling CIS you can instantly see the DPCs drop to normal levels when the CIS drivers/services are removed, which is pretty ironic as there’s usually a latency spike when installing/uninstalling something.

The issue is still present after a fresh install of CIS.

Core2duo E4300
Abit AB9 QuadGT motherboard (integrated realtek NIC)
4gb ram
Vista x64 SP1 with admin rights and UAC on

Hi I use csi 3.8 plus nod 32. I also get high cpu readings but they calm down if I disable AV maybe nod is the culprit?

i don’t think so. if it was nod32 problem it was already manifestated on comodo 3.5

nice reply and thank you so much.
I would love to se comodo developers talking with us

I also noticed that CIS is heavy in resources while starting of pc, my pc just halt on black screen for like 20-30 sec. then everything loads and it makes process slow, if there is bug rectigfying it might help.
I m using windows xp sp 3, 512 ram, 845 motherboard. P4 processor. so its like my pc is slow compared to new pc’s but still my ram is sufficient enough to install CIS so if there is anyway to reduce system resource usage to minimal that might be very welcomed by me and other users like me.
Please do something about this problem.

Uninstall nod then install avira see if you get the same cpu issues? I don’t on a spare laptop!

Since upgrading to CIS 3.8, firewall module only, I have experienced sound glitches when loading network trafic. Situation seems to get worse with time, and is really noticable when DPC latency is high, see screenshots below (taken using the tool provided here: http://www.thesycon.de/deu/latency_check.shtml)

Screenshot 1 is with FTP uploading, about 10 hours after a reboot: average latency
Screenshot 2 is with upload stopped: better
Screenshot 3 shows the transition when starting uTorrent : the change is noticable
Screenshot 4 is with uTorrent and a video playing. Even after the video has stopped, some red bars remain

I will keep monitoring overtime until I can hear sound glitches again.
Clearly network activity impacts DPC, no doubt about it.

One thing I noticed is some kind of memory effect: it would seem that at some point only a reboot can fix things when it gets serious.

I havent tested YET with CIS uninstalled or rolled back to 3.5 but I will when necessary.

Currently running CIS 3.8.65951.477, Vista 32 bits, fresh install - with or without AV

[attachment deleted by admin]

Here’s a few screenshots.

The first one is with CIS 3.8 and a night’s worth of data transfer with uTorrent.

The second one is the same, but with CIS 3.5. 3.5 seems to bump the DPCs a bit too, 100 units or so, but it’s perfectly acceptable compared to the new version and it doesn’t build up as it does with 3.8.

The third shot is a few minutes from the xperf graph with CIS 3.8 and 12+ hours of network activity. ndis.sys is the one with the most DPC time, but there’s a few others seeing some increases as well.
(dpclat_driver.sys is the DPC latency tool, which was running throughout the day)

[attachment deleted by admin]

Here is what I get now after one more afternoon of uTorrent without rebooting … it seems like we have a consistent pattern here! as an additional remark, CPU seems also higher

I havent tested the audio yet but I wouldnt be surprised now to experience a few glitches …
I can feel a test without CIS coming up later on … :slight_smile:

—edit—
sound glitches confirmed … CIS to be uninstalled … NOW :slight_smile:
— edit 2 —
CIS uninstalled, network traffic but no DPC activity so far, lets wait a few hours …

[attachment deleted by admin]

This what I get after a long period of network activity: uTorrent, FTP and so on.
Without CIS installed, no DPC, so I guess tests are conclusive
Comodo, can you fix this please, this bug makes CIS unusable :frowning: and thanks for the effort :-TU

[attachment deleted by admin]

I have this problem also and I hope this will be fix in next release.

Hi,

Maybe this trick (by now/v477) can be usefull: uninstall, do a reg-clean, and re-install in “SAFE MODE WITH NETWORK”.

This worked for me.

edit: I’m NOT an expert… just trying to help.