Comodo Update and Start Up Problem

If I’m not in the correct sub-page please point me in the right direction.
A couple of days ago I received notification that a Comodo update was ready to download and install.
After doing this I was told I needed to restart my PC.
After doing this I noticed that Comodo wouldn’t start upon PC start-up.
Normally when I turn on my PC, Comodo automatically starts up also but now I receive notification that there is a problem with starting Comodo.
I now have to go to my Desktop Icon and click ‘Open’ before it will start.
How can I get Comodo to start along with Windows ? Just like the way it’s always been.
Please see screenshot of new layout which I’m not happy about either. Looks suspicious.
Please help.

Same problem here. Someone has a solution?


Their has been issues updating using the internal updater. You should uninstall then reinstall using the standalone installer and optionally follow this guide to correct your issue. Comodo Forum

I think you mean ‘There’ as opposed to ‘their’. No matter. Thing is, what is the ‘stand alone installer’ ? I don’t even know what that is. While I’m here, can you please look at this screenshot and tell me what those 3 ticked (checked) boxes mean. In layman’s terms please.
I’m worried about leaving those boxes checked or what ones to uncheck, if any.

Short and Sweet…

Uncheck them all.

DNS provider is already supplied by your Internet supplier. Comodo has their own so if you leave that checked it will change one of your internet settings to use their servers instead of your internet supplier.

Cloud base means that it will check untrusted files against an online database to make sure they are legit.

Third tick just means if comodo crashs it sends a report back to comodo. Because they use vague terms on the data collected (e.g crashes. errors, clicks, ect) it’s not spelled out whats being sent besides the crash report so I would consider it “monitoring software” and uncheck it.

Just my opinion

I uninstalled Comodo, re-installed it, unchecked those 3 boxes and it solved nothing. I uninstalled it again, re-installed it and this time left the 3 boxes checked - again it solved nothing.
Does no-one actually have a solution to this problem ?


yes here as well. Uninstall and re-install with cispremium_installer_6100_08.exe (is this the ‘stand alone installer’ ?)

No solution, still get the COMODO security agent could not be started. Must this still start manually.

Hi Wallace1297,

Sorry for the trouble caused. We are going to fix this very soon.
Thank you so much for understanding.

Kind Regards,

Same problem here - uninstalled/reinstalled 4/5 times and ran all the cleanup tools thinking it was a computer issue.

It installs fine, then on requested reboot, up pops the ‘could not start service’ dialogue.

As the comodo staff member replied… no solution yet and no way to downgrade. At present I have removed Comodo and will wait until this “Beta” update is fixed before I even consider using it again. I know many will say this isn’t a “Beta” but there are too many posts about it to consider it a minor bug in the code.

In my case when I rebooted it went to a blank screen and failed to finish updating so I had to use safe mode to remove it. At present I’m running without a software firewall but have activated my routers internal firewall so that should work until I decide what to do.

Still disappointed that this update nuked a great working version 8 that had no issues.