Comodo update always fails, even after reinstalling it

Good morning,

Comodo says all the time that it cannot update itself. Reinstalling Comodo did not help.

It could be connected with Windows Updates which also fail. I have followed the tutorial on msdn but it did not help (following indicated steps shows errors which are not considered in that article at all).

I use Windows 7 Professional with Service Pack 1, 64 bits, 4 GB RAM, processor INtel Core i3-2328M 2.20GHz, Acer TMP453-MG. Windows was originally preinstalled at the moment computer was received.

Please find the attached screen shot.

Best regards!

[attachment deleted by admin]

Did you try reinstalling it by following the methods I suggest in this post? If not then please try this.

The uninstaller tools can often fix problems like this.

From the information you have given I am not clear whether this is a bug/issue.

For the moment I will transfer you to help so you can work through this issue with users and mods in this forum and hopefully resolve it. I hope that is OK.

Please ask any mod to move this report back to the bugs forum if it becomes clear that it is a bug/issue.

Best wishes

Mouse

May be you are infected. The blocking of Windows update and not being able to update could be the result of this.

Try running the following scanners and see if that helps:
Hitman Pro
Malwarebytes Antimalware
Super Antispyware
TDSS Killer

See if these program can update or connect to the cloud (in case of Hitman Pro).

Hello,

i got a similar problem and this is NOT an infection.

1st of all a short description of my system:
CIS Version 6.0.264710.2708, database 15816,
complete new installation of my computer - > this means no update from CIS 5
Windows XP professionell 32Bit SP3 including all latest windows updates
AMD Athlon 64 3200+ 2Ghz
ECS KV2 extrem lite mainboard with VIA K8T800 and 4GB memory

…and now the bug:

  • i clicked on the green refresh-button (with 2 green arrows on it) on the “Home”-Screen of CIS to
    check for new virus database and new program updates
  • 1st of all the update of the virus database was done as normal
  • and then it shows me that a program update is available…i clicked on this link and then on the button “update” for execution
  • at once i received a window showing me that a reboot is necessary for execution and 30 minutes are left for this reboot (2 buttons on it - reboot now or postpone)
  • after doing this reboot i expected to have an updated version of CIS on my computer…but…nothing changed…i got still CIS Version 6.0.264710.2708 on my computer!!! no update!!!
  • i tried to click again on the green refresh-button (with 2 green arrows on it) on the “Home”-Screen, but at once i received again the message to reboot and 30 minutes are left…
  • after the 2nd reboot the same, after the 3rd the same, after the 4th reboot the same…etc

I tried to check if this was a onetime error during installation of the CIS update by installing a backup which was done before the CIS program update was executed (with Paragon Harddisk manager)
and the result is…the same error after trying to do the CIS program update…

I checked as well if my computer is infected by doing a scan with latest version Comodo Cleaning Essentials.
Result: no infects

What does this mean? is my CIS installation not able to do an update anymore?
Are you aware of this bug already?
Please inform me when this bug is fixed by providing an errorfree update (process)

Thank in advance for your support,

theCount

There is no update yet for v6. The reboot after installation is mandatory and does not reflect a program update.

The odd thing is the continuous request for a reboot when you are running the updater. The reboot request only happens after you ran the updater. Is that correct?

Please run Diagnostics and see if that brings any insight.

Hello EricJH,

tx for your fast reply and sorry for my late reply ( i enjoyed some days vacation)

Sure, understood there is no update on CIS 6.0.264710.2708 is available…
but according to my description it shows (after fresh installation) that there is one update available (after click on the green refresh-button)…about this i’m 100% sure…

…and after executing the update (by clicking on the update link) i have to reboot my computer and nothing changed…still CIS 6.0.264710.2708 unchanged on the computer…

oh sorry …not really unchanged…now i got - as you stated, this is right - a continuous request for a reboot when i running the updater…but this is a bug and should be fixed…

What do you mean with “Please run Diagnostics and see if that brings any insight” ?

Regards,
theCount

Hi theCount,

In the main GUI click on the little question mark in the top right corner, hover over support and you can then see the diagnostics function.
Clicking on diagnostics will generate a report.

Another one here - Cannot update AntiVirus