Comodo update always blocks WinSCP

I updated Comodo to the latest version (3.8.65951.477), and now it ALWAYS blocks WinSCP from working.

WinSCP had already existed in a Network Security Policy as a Trusted Application, and worked in the past. After this update, all FTP connections using it fail. I deleted the policy and re-added it, but no go.

If I kill Comodo, WinSCP is still blocked - this is another issue that really should be fixed - Comodo rules still appear to be in place even when you kill Comodo, which is just WRONG.

In any case, I have to set the Firewall to Disabled, and THEN WinSCP can once again connect.

Anyone else having this problem?

  • Tim

No, i’m running Winscp fine without trouble, but i mostly use SFTP.

It could have something to do with your Global rules, how did you configure them ?
Did you run “Stealth port wizard” ?

Have you tried to ftp, using the default windows ftp client to see if that also fails ?

Thanks for the suggestions. My question about why the firewall rules are still in place when I exit Comodo has been answered elsewhere. Now it’s just a question of why it blocks WinSCP FTP connections for me.

I didn’t run the Stealth port wizard, I don’t think. I’ll check my global rules.

  • Tim