Comodo Uninstall Problem


I installed “Comodo Firewall Pro 3.0CFP_Setup_3.0.20.320_XP_Vista_x32.exe” on a friend’s laptop (Windows Vista Home Premium) in March 2008 and everything had been going fine since then.

However, recently she had a problem with a loop - comodo screen would appear and ask permission to allow various programs to access various other programs and clicking “Allow” “Deny” or “treat application as installer” had the same effect - the window kept re-appearing. This meant she could not access anything else on the laptop.

I succeeded in disabling Comodo but when I restarted Comodo the same loop reappeared.

She then had no Internet connection. She could still receive Windows e-mail but the network window indicated no internet connection.

I resolved this by disabling Avg antivirus and then and uninstalling!!

When I installed another a-virus(Avast), again the internet connection terminated.

I then tried to uninstall Comodo but it will not uninstall.

I have tried everything suggested in the forums to uninstall Comodo but have failed!!

When I click on the uninstall button, a message appears telling me:-

"Comodo Firewall Pro Configurator has stopped working

A problem caused the program to stop working correctly. Windows will close the program and notify you if a solution is available"

-I have tried different uninstallers

-I have tried cmd dos window

-I have tried to reinstall Comodo

but the above message appears each time.

By the way - Windows security centre reports that Comodo is turned on but I have checked task manager and there is no entry for Comodo there.

She now has only internet access without a-virus or firewall.

Can anyone help please?


Try running this tool:

When downloaded, you’ll need to unzip the archive. Can be done with Windows built-in tool, or by a third-party tool such as 7-Zip or WinRAR. Seeing as your friend is using Vista, you’ll need to right-click the file ‘CFP 3 File+Registry Cleaner’ and choose ‘Run as an administrator’ from the menu. This will remove the remains of CFP 3, and also take care of the faulty reporting from Windows Security Center that CFP 3 is running.
When done, reboot your computer, and download the latest version of Comodo Internet Security from here:

If you only want the firewall installed, check that during the installation:

I believe that for security purposes, the HIPS-module (Intrusion detection system - Wikipedia), Defense+ will have some basic protection mechanisms enabled (such as termination protection). If this should be the case, and you should wish to disable Defense+ completely, you can do so by going to Defense+AdvancedDefense+ Settings and check Deactivate the Defense permanently (Requires a system restart) once you’ve installed the program.


Thanks for your suggestion.

When I run the file like you suggested, it states to make sure that Comodo is uninstalled before proceeding.

I have never uninstalled Comodo, as I have been unable to do so.

It still appears in the start menu and starts up but does not function properly. e.g. Diagnostic will not function.

Should I still run the .bat file?

The batch file is meant to remove left-over files and registry entries, but can also be used to uninstall CFP 3 (in case standard method doesn’t work), so yes, you should run it. The important thing is that cfp.exe and/or cmdagent.exe aren’t active in the Task Manager (which you reported that they aren’t).

Hi again,

ran the batch file and hopefully Comodo is uninstalled.

I now have no internet connection.

Diagnostics mentioned possible problem with network adapter “Broadcom 440x 10/100 Integrated Controller”.

When I checked Network Adapters yellow warning triangle beside:-

Broadcom 440x 10/100 Integrated Controller - Comodo Firewall Miniport
Intel(R) PRO/Wireless 3945ABG Network Connection - Comodo Firewall Miniport
WAN Miniport (IP) - Comodo Firewall Miniport
WAN Miniport (IPV6) - Comodo Firewall Miniport
WAN Miniport (Network Monitor) - Comodo Firewall Miniport

Any suggestions?

Right click on all of the Comodo entries and choose to uninstall. Don’t reboot when requested.

When done click on View in the menu bar → select to show hidden devices → under Non plug and play drivers look up Comodo related entries → when you find one or more select them one by one → right click → uninstall.

When done with the above reboot.

When I clicked to uninstall, window appeared and process seemed to occur but all entries are still there in Device Manager. I never got a prompt to re-start.

I re-tried numerous times but still there.

There were no hidden Comodo devices, under network adapters.

When I tried to enable the problem entries and check the properties it states that

“Windows cannot start the hardware device because its configuration (in the registry) is incomplete or damaged. (Code 19)”

Still no internet connection - same message as before when I try and connect

Problem with Broadcom 440x 10/100 Integrated Controller etc.

Thanks for any help.

(By the way I am going away on holidays later today)

Please try here the post might help regarding miniports.

Thanks for the suggestion.

I looked up the problem but am not clear about the solution.

"Ownership must be taken and then inheritable permissions systematically removed from every key which is TEDIOUS work. "

How do I do this?

I have also got the “If I go to NT_INSPECTMP/000#/Properties I am told immediately upon merely clicking the key that the data cannot be displayed, access is denied” message.

I am now trying system restore.

We are gonna take a look to see if there are some old drivers of your previous security programs or Comodo are still around. Go to Device Manager → View → show hidden devices → now look under Non Plug and Play drivers → when you see a driver that belongs to your previous security programs or Comodo click right → uninstall —> do this for all drivers → reboot your computer.

After this try removing the miniport drivers again. Does that help or does it stay the same?

worked great, thanks,
FYI Comodo affected my mozilla and itunes. both work like they should after following these instructions then going into connection properties and removing it from there.
hope this helps others as it took three hours of my life away.