Comodo system cleaner stops Windows XP from rebooting after system clean

I installed and ran Comodo on a Windows XP Pro system and when the system attempted to reboot all I could get was the Windows start up Logo screen which just keeps runing and not allowing a reboot. Safe mode will not work either or any of the F8 key options. I have Norton 360 installed and wonder if it could of contributed to the problem. I now have a computer with several years of important files and programs that I cannot use…
Has anyone had this problem and been able to correct it ?

                                                                                                        Many Thanks


have you tried reverting back to a known good configuration?

Thank you for the response - yes I done that with the same results…

this is the only thing that comes to mind,

Step 2: Begin the repair process

* You must boot from your XP or 2000 CD. Please make sure it is the same version of Windows that is currently installed on your computer (ex. XP Home cannot repair XP Professional). Place the CD in your CDROM and start your computer. Newer versions will work as well (ie. Windows XP Pro SP2 CD will work on an older WinXP Pro SP1 installation)

  Before the Windows logo appears, you will be asked to press any key to boot from CD, so do just that.

  If you are unable to boot from the XP/2000 CD, then please check the last step in this short guide.

Step 3: System repair steps

* A blue screen will appear and will begin loading XP setup from the CD.

  RAID/SCSI/Unsupported UDMA users:
  You will be prompted to "press F6 to install any third party SCSI or RAID drivers". Most users will not have to press F6, but if you are running RAID, SCSI or unsupported ATA controllers, then you need your controller drivers on a floppy disk. If you are unsure whether you have RAID/SCSI, then simply let the CD load without pressing F6.

  Once completed, you will be confronted with "Windows Setup". You will be asked to setup up Windows, or repair Windows with the recovery console. Choose the FIRST option, NOT recovery console.

Choose F8 to continue.

* Next, Windows Setup will find existing Windows XP/2000 installations. You will be asked to repair an existing XP installation or install a fresh copy of Windows XP/2000.

  If no installations are found, then you will not be given the option to repair. This may happen if the data or partition on your drive is too corrupted.

* That should be it. Windows XP/2000 will appear to be installing itself for the first time, but it will retain all of your data and settings. Just follow the prompts, have your CD-KEY handy and hope for the best!

Thank you - I’ll give it a shot…

Since you cannot get into XP there are a few things you might try.

The first may or may not work but it is worth a try, unplugh your computer from the wall outlet for about 20 or 30 minutes and then reboot. If anything is in memory this should clear it, but as I said this is a 50/50 shot. No guarantees but it cannot hurt.

The other is doing an inplace upgrade /repair. If you have a disk and you have updated to SP3 it will need to be slipstreamed on that disk.
Read about XP InPlace Upgrade Repair on another computer.

If you do not have a Disk and your backup is on your HD, read about how to use the recovery console.

There are several here who can work with you in utilizing either.

When you use the InPlace Upgrade /Repair (not reformat) it looks scary when it starts deleting items but at least for me all my settings and files remained intact when finished.

As I said work with someone here that has done PC repair and used these tools.

Two other Microsoft tools that many overlook (if you can boot into your system are
1)right clicking on your primary drive usually C and choosing properties then Tools then error checking
2) The System File checker SFC /scannow also helps with minor errors and missing files. But again what ever Service Pack SP2 SP3 needs to be integrated with XP.

Good Luck

I’ve done as you suggested with the same results on boot Logo screen, I even installed a new Windows XP version which must have made a new partition to D: drive. The new version works fine and I have updated all the latest updates. I can go to the C: drive and see the origional Windows installation and all of my files and programs - however I cannot run most due to the registry conflict. Comodo must have removed a critical file in the startup process. I wish I knew which file/files are causing the problem…


It appears that the following files are required for Windows XP Pro:
Table 29-1 Windows XP Professional Startup Files

File Name
Disk Location

Root of the system partition
The operating system loader.

Root of the system partition
A file that specifies the paths to Windows XP Professional installations. For multiple-boot systems, Boot.ini contains the operating system choices that display on the startup menu.

Bootsect.dos (multiple-boot systems only)
Root of the system partition
A hidden system file that Ntldr loads for a Windows XP Professional multiple-boot configuration that includes MS-DOS, Windows 95, Windows 98, or Windows Me. Bootsect.dos contains the boot sector for these operating systems.
Root of the system partition
The file that passes information about the hardware configuration to Ntldr.

Root of the system partition (required for SCSI or Advanced Technology Attachment [ATA]controllers with firmware disabled or that do not support extended INT-13 calls).
The device driver used to access devices attached to a SCSI or ATA hard disk whose adapter is not using BIOS. The contents of this file depend on the startup controller used.

The core (also called the kernel) of the Windows XP Professional operating system. Code that runs as part of the kernel does so in privileged processor mode and has direct access to system data and hardware.

During installation on single processor systems, Windows XP Professional Setup copies Ntoskrnl.exe from the operating system CD. During installation on multiprocessor systems, Windows XP Professional Setup copies Ntoskrnlmp.exe and renames it Ntoskrnl.exe.

The hardware abstraction layer (HAL) dynamic-link library file. The HAL abstracts low-level hardware details from the operating system and provides a common programming interface to devices of the same type (such as video adapters).

The Microsoft Windows XP Professional operating system CD contains several Hal files. Setup copies to your computer the file that fits your hardware configuration and then renames the file as Hal.dll.

System registry file
The registry file that contains the data used to create the registry key HKEY_LOCAL_ MACHINE\SYSTEM. This key contains information that the operating system requires to start devices and system services.

Device drivers
Driver files for hardware devices, such as keyboard, mouse, and video.

You can use this tutorial to get back in your old Windows. This method is using system restore information with an intriguing and nifty method. This works when you are completely locked out of Windows: .

In this case you can do the backing up and copying of files from your second windows installation instead of using the command line.


We are aware of this issue. There is no critical file being removed by Comodo System Cleaner. The problem is with Norton 360 which blocks CSC’s start-up registry keys. We tried many ways of solving this problem, and the only efficient solution was removing the norton drivers in “C: \ windows \ system32 \ drivers \ N360”. After that, Windows booted in normal mode just fine, the CSC Finalize/Restore window appeared as it should.

In your case, the solution is this : Boot into the second Windows on D drive, and delete the N360 folder in “C: \ windows \ system32 \ drivers \ N360”. Then boot in normal mode on XP from C drive, and that’s it, it should load the operating system and work as it did before the Norton-CSC conflict.

Considering this situation, you have to choose between Comodo System Cleaner and Norton 360 as they don’t mix together.

Thank you for your support.

hi… im also having problem like rick… i hav 2 partition both windows xp sp3. i run csc in my d partition and it runs good so i decided to install and run it in my c partition… thats wen the problem start… i try also the safemode nd last good config.but it didnt work… my antivirus i c drive is pctoolsantivirus and zonealarm firewall… my d partition’s antivirus is nod32… can u help me with my problem…



Please read the discussion concerning the problems encountered running CSC when Zone Alarm is installed:

Thank you for your support.

I edited my previous post. I added the promised url to a procedure to repair Windows while being locked out of it/ Here is the url for those who don’t feel like scrolling up: .

My problem also was the same as above. Except, now my machine will not find my hard drive! Tried safe mode- nothing valid. Last known restore-nothing again. Tried unplugging unit for 30 minutes. no luck.Confused and don’t what to try next.


The solution posted above for the Norton 360 removal, which caused the problem from the thread’s title works ( rick441 confirmed it ). But if your machine can’t detect the hard drive, that’s a different issue( potentially hardware ). Although, if your hard drive is not recognized, how could you select Safe mode or Last known good configuration which are options available only when the operating system is loaded from a recognized HDD ? Please be more specific describing your problem. Unplugging unit won’t ever solve any software problems, only sometimes, if they are hardware related.

Thank you for your support.

I have had a similar issue:

  1. Ran system cleaner for first time this afternoon.
  2. When I rebooted this evening i received a windows error message telling me the config\system file was missing or corrupt.
  3. Last known good config etc did not work.
  4. Was able to repair, the hive however appear to have no restore points to recover an up to date hive.

Is there a list of incompatible programs which may have caused this issue? (I am running AVG 8.5 Free)

I ran Comodo firewall some time back and loved it until updating to a newer version corrupted that system and decided it wasn’t worth the trouble. Now I have a similar situation with this.


In order to assist you in solving your problem we need to have more details regarding the circumstances surrounding your scenario and error occurrence. Please describe a few elements needed by us to reproduce your scenario :

  • Your Operating System (and whether it’s 32bit/64bit);
  • Version of Comodo System Cleaner used;
  • Security Software Installed;
  • How you produced the problem;
  • How you tried to resolve the problem;
  • Screen-shots with the error (if any);
  • Post Memory Dumps on crash if you encounter any;
  • All log files of CSC, if you had logs enabled;
  • Any other Additional Information.

Thank you for your support.

I have the same problem: after installing the version 2.0.107697.4 of Cleaner, I ran Registry clean, it showed 364 errors.
I chose to correct all errors. The next reboot after that came up with a black screen after showing the Microsoft logo.

I use the Acronis backup system. With the help of the bootable CD of Acronis I could start Acronis which has an option to restart Windows. It encountered the same problem but gave me the option to use the restore point taken prior to the installation of Comodo Clean.

After the restoration windows started OK. I reinstalled Comodo cleaner, ran it again, the same 364 errors. This time I did not correct them, but just closed Comodo cleaner.

Although Comodo Cleaner is now installed and can run, I have no problem rebooting.
Obviously the problem is caused by the removing of Registry errors.

Some essential registry entries are removed.

What are they?


Please use the latest Comodo System Cleaner, which reached version 2.0.111095.7:

Thank you for your support.

Thanks for your help!

The installation of the new version fixed the problem.