COMODO System Cleaner 2.0.110158.6 Public Release BUG REPORTS

Portable Version STILL does not work. Version 1 worked fairly well and loaded.

  • Windows XP SP3 32 bit;
  • Norton AntiVirus;
  • Double Clicked CSC.exe;
  • Keep trying new version. Deleted/wiped all previous versions from USB drive;
  • See attached Image;
  • N/A on Memory Dumps;
  • N/A on All log files of CSC;
  • Have the following Visual C++ Loaded
    vcredist_x86 2005 SP1 ATL Security Update.exe
    vcredist_x86 2008 SP1 ATL Security Update.exe;

[attachment deleted by admin]


Please remove everything related to CSC on your USB drive and then download it again. The error might appear if you’re missing a file (dll). Please let us know if this is the case.

Thank you.

  • Your Operating System (and whether it’s 32bit/64bit); WinXP Pro SP3 32 bit
  • Security Software Installed; CIS 3.11.108364.552 CFP, CAV, Defense+ Safe Mode and On Access
  • How you produced the problem; Ran Windows Update (more info below)
  • How you tried to resolve the problem; Temporary Solution Below
  • Screen-shots with the error (if any); n/a
  • Post Memory Dumps on crash if you encounter any; n/a
  • All log files of CSC, if you had logs enabled; n/a
  • Any other Additional Information; n/a

On August 26th, I ran a Windows Update (KB970653) and when I rebooted the computer, services.exe spiked the CPU to 100% and consumed my memory and my PF Usage for about 15 minutes until it eventually settled down. I was unable to use the computer while the spike was running. Restoring the computer to just before the update was installed cured the problem and I wrote it off to a Microsoft glitch.

On September 9th, there were 4 more updates and I installed them through Windows Update. Again, I got the CPU, memory, spike and did a System Restore to fix it. I have researched this for 3 days now (trying a myriad of things to cure the problem) and have found the solution:

It was caused by CSC 2.0.110158.6. I had CSC installed and didn’t have any problems until the August update attempt.


1: Installed only 1 of the 4 updates.
2: Rebooted the system and got the CPU spike.
3: Uninstalled CSC 2.0.110158.6 with Revo Uninstaller.
4: Rebooted and spike was gone.
5: Installed another of the 4 updates.
6: Rebooted and spike was gone.
7: Installed CSC
8: Installed another of the 4 updates.
9: Rebooted the system and got the CPU spike.
10: Uninstalled CSC
11: Rebooted and spike was gone.
12: Installed the last of the 4 updates.
13: Rebooted and spike was gone.

Temporary Solution:

  1. Uninstall CSC before running Windows Update.
  2. If you are already experiencing the problem, uninstall CSC reboot and reinstall.

I thought I said that I deleted all traces of CDC from USB…
Anyways, it appears to be an issue with the corporate network. I took the Lappy home and tried the software. It ran, no error using my router and ISP. Error still shows up when connected to the corporate network. I don’t understand why? unless the “auto update” feature, which I turned off, is programmed in C++. Version did not have this problem running off of the corporate network … and still doesn’t as I still have it on another USB stick and just ran it.

  • Your Operating System Win XP Pro SP3 32Bit
  • CIS
  • Installed
  • Deleted Folder, reappears when CSC is run again.

I am having this same problem on windows XP

C:\Documents and Settings\Owner\Application dataComodoGroup\CSC\Cache

It just looks like a \ was forgotten in the coding of a script that creates the cache folder. Does not create any problems but is annoying when looking at the user folder.

Wow! I got my Application Update today and it didn’t change my personal settings! Kudos to the devs for working on this! Please don’t forget to look into the Windows Update problem mentioned here. You are making great strides! ;D


The issue is already fixed for the next release. Thank you for your support.

Thank you so much for your post and information provided. We are now closer in finding a solution to this problem. The devs are currently working on it and we will keep you updated on this matter.
Thank you for your support.

I did forget to mention that it’s not just running the Windows Update from the web that’s the problem. During my troubleshooting, I downloaded the separate update .exe files from Microsoft and when attempting to install them without using the Internet, I got the same CPU spike. Uninstalling CSC was the cure.

  • Your Operating System: Windows Vista Ultimate 32bit
  • Security Software Installed: CIS 3.11, SpywareBlaster
  • How you produced the problem: PerfectDisk 10 system defrag will not run with CSC installed
  • How you tried to resolve the problem: uninstalled CSC
  • Screen-shots with the error (if any): NA
  • Post Memory Dumps on crash if you encounter any:NA
  • All log files of CSC, if you had logs enabled: log files have no bearing on this problem
  • Any other Additional Information: I don’t know if version 1 of CSC caused this problem with PerfectDisk 10 system defrag or not. I tried to download version 1 of CSC today, but I got a DNS error and could not download the file. I tried several links for various versions of CSC version 1, but none would work. I don’t know exactly how long I have had this system defrag problem with PerfectDisk 10 because I had it set to automatically do a system defrag every week. The problem could have existed with CSC version 1, but I don’t think so. Anyway, PerfectDisk 10 will do a regular SMARTPlacement defrag, but not a system degrag. It starts to do a system defrag when you set it and reboot the computer, but instead of going ahead and performing the system defrag, the computer reboots again to a screen that asks you if you want to initialize a startup repair or start the computer normally. CSC should not cause interference with other programs like this.


We will investigate this problem.
Thanks for the feedback!