Comodo Security Agent error message


Recently I’ve been getting the following message after starting Windows 7 “Comodo Security Agent could not be started. Would you like to tun diagnostics to fix the problem?” So, I run diagnostics and get the message that it did not find any errors and it saves a log . I’ve also noticed that my current Router is very slow in starting up at the same time. After the Comodo diagnostic is run, everything appears to be work correctly, including CIS 6.0. Any suggestions will be appreciated. Thanks.

As this may be fixable, and not necessarily due to a bug, I will temporarily move this to the Help section of the forum.

Thank you.

Same prob here, and I have noticed when the prob occurs, task manager shows 2-4 instances of cavwp.exe & when prob doesn’t occurs taskmanager shows usual 4 processes. I am getting this error often now & sometimes CIS loads fine.

I am reinstalling CIS now & check the prob solves or not.

Also 2 instances of databases in scanners folders have been reported many times by users, is this a confirmed bug & will be solved with next updates?

Reinstalled thorugh add/remove components i.e reintsalled both FW & AV checking/unchecking respectively.
CIS showed secure & every function was working fine but performing diagnostics showed error that cannot be solved automatically, create diag report & I created diag report. But I restarted the system & checked again but this time diag showed no probs.

Still attached diag report for review.

And about the main prob for which I reinstalled CIS, will see & post here if the prob occured or not.

[attachment deleted by admin]


My temporary work-around for this problem, once CIS & my router are working correctly, is to Hibernate Win 7, instead of shutting it down. When I resume, everything works correctly without any delays or CIS error messages.

Uninstalled CIS & manually removed leftovers. Reinstalled CIS & probs solved for now. Will check for few days & post here.

I thnik CIS somehow got corrupted.

Hi Naren, Thank you for the update. I am interested in your confirmed findings.

Seems my problem is fixed! Thanks naren for the idea. Cheers. :BNC


Everything fine here too.

Yes Same problem here.

Windows 8 - “Comodo Security Agent could not be started. Would you like to tun diagnostics to fix the problem?”

And I can not uninstall Comodo to try your solution. Anytime I try to uninstall, it gives "you have to restart for the installation to complete. I restart. And can not uninstall. Same goes over and over again.

My wife’s Windows 8 laptop has this exact same problem. I tried reinstalling Comodo the other day, but the problem returned within a few hours, actually. The Comodo window won’t even pop up when we click the icon in the toolbar and she can’t scan her computer for viruses.

Comodo runs well on my Win8 laptop.

Any solutions or suggestions?

When reinstalling CIS please follow Most Effective Way to Reinstall CIS to Avoid/Fix Problems by my colleague Chiron. It will provide a reliable and clean starting point.

What version of CIS are you using? Please make sure not to skip the part about making sure remnants of previously installed other security programs.

Sorry to grab this “old” topic, but it still remains actual.

Got a fresh Win 7 64 Installation and tried different Versions of Comodo IS & Comodo Firewall, without success. All uninstalled & Cleaned between.

Anyway I figured out an “Active-X Com Registry Error” occured by the Comodo Setup itself.

Hope this bug will be fixed in time.

If you have the time and energy please consider filing a bug report in the Bug Reports - CIS board following the format as described in FORMAT & GUIDE - just COPY/PASTE it!.

Reporting of bugs is strictly moderated to make sure Comodo gets clear bug reports. So, please make sure you closely follow protocol. That way your report will certainly be seen by Comodo staff.

On en_windows_8.1_with_update_x64_dvd_4065090.iso impossible to uninstall, insufficient privileges and can’t open Comodo due to the Security Agent message… Running in Oracle VM (which freezes and reboots, even though Comodo service is set to restart and not the computer; from services.msc)


In the past CIS would not run properly in Virtual Box due to limitations of VB.

Try using the Geekbuddy removal tool in Safe Mode to remove CIS completely.

Hey, thanks for your time and for the reply. The problem is, that I’ve tried at least 5 (to 10) different firewalls && NONE of them have the ease of use that Comodo has (acting in Manual and with full prompts, to be used as a rule-based firewall - for convenience and functionality on this box, and on others, too).

Practically, w/o Comodo - it’s pretty much impossible; ever since Kerio Personal Firewall 2.15 (previously Tiny Personal Firewall) came out of the picture (a few Windows versions back). No idea what I should do… Reinstall one of the previously-tried programs and try to wrangle it into submission. Tnx again.

(Managed to remove through System Restore, or I’ll wipe it clean; no big deal - the problem is: how to get a functional firewall :))

Edit: Just can’t believe it… All other firewalls have application control linked with the firewall and similar… Or overly-complicated interfaces… Don’t they understand: we need the application+protocol+port allow/deny and ask for the rest for that application & that’s it, so simple.

Windows 8 asks for dozens for connections, for all sorts of things - just sitting idle at the desktop. I don’t want to allow any of it, didn’t ask for it, don’t want it (as IF we should trust the integrity of the services asking for connections - and in Windows, too, lol); but I want the networking & in other firewalls it takes a space-engineer to configure all this, while Comodo does it in a couple of clicks - plus the editing of rules is very simple. Argh, gonna lose my mind for sure. xD

There seems no way to fix this problem with v7 - i’ve tried all solutions multiple times :frowning:

Is there any link to get a recent version like 6 or 5 to download?

Many thanks.

Try Filehorse: Comodo Internet Security Download for Windows / Old Versions / and Comodo Internet Security Download for Windows / Old Versions /

The latest v6 works well. Many thanks!