COMODO Security Agent could not be started


I pre-warn I’m visually impaired which makes things extra difficult for me. So DON’T tell me to ‘search the forums’. There are MANY refs to this and I have to use TTS to sift through the noise and try to find anything helpful. Yes, no prizes for guessing I’m getting pretty upset about this.

This is getting ridiculous. It seems this problem, the ‘COMODO Security Agent could not be started’, has been had by may for years now and yet you lot are no closer to providing a solution.

I have tried to re-install cfw for over a week now (this time) and I get the above error EVERY time after I reboot. When I click to run the diagnostics tool, nothing happens.

I followed all the advice I could find on this forum including running the uninstall, running the TWO removal apps and batch file and also going through my system and physically deleting anything called ‘COMODO’ and CIS on my system drive. Geez, you leave a lot of ■■■■ behind!

I run Windows 7 64bit SP1, I have uninstalled any and ALL apps that even hint at having anything to do with security, antivirus, malware - no protection whatsoever.

I have gotten pretty good at fixing the usual Comodo ‘no internet’ after it craps itself’ problem. I go straight to my network adapter settings abd uninstall the Comodo Firewall driver which seeming defaults to BLOCK ALL when th app fails.

I have used and sworn by CFW for years now, but I can no longer recommend it to anyone based on my problems with it over the last year. On average, I have had to reinstall it every 2-3 months after getting the above errors and it gets harder to get it working again each time. This time, it won’t co-operate at all.

One last thing I’ll try is to use an old 'stand-alone installer version of cfw and get it to update itself later. If that fails, unless someone can give me a fix quickly, I’m going shopping elsewhere. BTW, I’m getting tired of uninstalling the PUP - Dragon. I already have a browser thanks.


Nothing Eh? Imagine my shock. Here’s the next installment.

A further update on trying to get this thing to install. I have stand alone installer version ‘Comodo Firewall cfw_installer_6106_53.exe’.

I removed all traces (that I could find) of cfw by following the removal steps in the forum. Uninstalling with REVO, running the two uninstallers, the ‘COMODO Removal Tool 2014 - Mods version.bat’ steps 1 & 2, and ‘Uninstaller Tool.exe’ to take out Dragon, Geek Buddy, and anything else in there. THEN, I re-booted and set about deleting MORE leftovers like appdata and program file foders. Geez, this thing is like a bloody virus to get rid of.

Now, I unplugged the LAN cable so the internet couldn’t interfere, and tried installing the older CIS version listed above. NOPE… WHAT NOW?

‘COMODO Cloud AV Installed.’ WHAT???

No, it’s not. When did that happen against my will? I searched and there it was. Imbedded in my Registry. I had to delete many entries. It seems the Firewall Uninstaller imbeds ‘Comodo Cloud AV’ entries into the Registry. Presumably to prevent people from installing older versions. Nice.

Now tell me. I deleted all registry entries and traces I could find of ‘Comodo Cloud AV’ and yet the installer refuses to budge saying it’s installed on my system.

Then I find this in my startup…
CCAVInstaller wscript.exe “C:\Users\Altair\AppData\Local\Temp\CCAVInstaller.vbs”

But wait!, there’s more. I find a registry key I can’t delete. Even using SYSTEM privilege can’t delete it.

Invalid file reference ImagePath - “c:\program files\comodo\comodo internet security\cmdagent.exe” HKLM\SYSTEM\CurrentControlSet\services\CmdAgent

So where else on my system does the Comodo cfw installer get the idea I have 'COMODO Cloud AV Installed prey tell?

It would seem the only way to fix this is to re-install Windows. That’s not going to happen.


Hi there,

From your description, it looks like registry corruption (as I’ve said in similar topics; incorrect permissions). Running as System is usually not enough.
I’d recommend running regedit as TrustedInstaller. Here’s a tool : GitHub - jschicht/RunAsTI: Launch processes with TrustedInstaller privilege

Hope it helps.


  1. The reason why I’m not posting a complete guide is because it’s dangerous. You should use extra caution when messing with registry. You can find more info by utilizing search engines.
  2. Such corruption may cause subtle issues. For example, you cannot assume that by fixing every key that is used by Comodo you will get it working. That’s why you should consider resetting permissions for all keys which takes some time depending on system performance and so on.

Hi There again

An Update. Seeing as no one here had an answer to my problem of getting the Firewall to work, I resorted to the only tried and true method I know: Leave it a few months, get the latest installer, repeat steps until something different happens.

This time I installed this version - cmd_fw_installer_10299_79.exe

Ah! After an apparently sucessful install like all the other times, the mandatory reboot spat the usual cmd agent error as before, BUT, this time the diagnostics actually ran !!

But, no fixing to be seen. I did get a log dump which I’m attaching. I hope some kind soul can look it over to maybe get my fave Firewall onto my PC again. I do miss it.

Thanks folks


Anybody home?

Run the official uninstaller tool and nothing else, then when it completes attach the log it generates.