Comodo Security Agent could not be started


I updated Comodo Internet Security and then rebooted, upon rebooting I receive the error message “Comodo Security Agent could not be started. Would you like to run diagnostics tool to fix this error?”. Clicking Yes just says that there were no problems found yet it still won’t start. I’ve tried running it as administrator but still no joy.

I’ve also tried to uninstall and reinstall as mentioned by the guide on this forum and it works OK right up until I update it again in which case I start getting the error message again.

I’m on Windows 8, Comodo is the only AV/ Firewall installed (other than Windows Firewall) and I’m using the 64 bit installation on a 64 bit machine. The only other weird thing I can see is that there’s nothing relating to Comodo in the startup tab within Task Manager and I thought that there was something there before…

Any suggestions of what I could try / where I could look?


Which version of CIS are you using?

Also, when you say that it works until you update it again, do you mean a database update or a program update? Also, do you mean check for updates or while it’s actually downloading and installing an update?


Comodo Internet Security 2013 - The version number on the installer is 6.2.282872.2847 if that’s any help. The version number on cis.exe is 6.2.285401.2860, let me know if that’s the right file I should be looking at.

Sorry, you’re correct - I wasn’t exactly clear with what had happened. Both times I’ve had it up and running with the latest databases when I’ll get a popup dialog that says “An update is available for this product, do you wish to download?” or something to that effect - I’m uninstalling again now to try and get the exact message. So, to answer your question, I believe it’s a program update as database updates don’t generally popup a confirmation box do they?


So this has happened for versions older than the V6.2.285401.2860 you currently have installed. Is this correct?

Correct, the previous installation file was from 6.1.276867.2813. That’s been working fine for a couple of months.

This may then be a problem which has been carried over during the updates. Please try creating a fresh installation by following the advice I give in this post and see if that solves the problem.