"Comodo Security Agent Could Not Be Started" - Yes, *another* thread about this!

I have seen literally dozens of threads on this problem, but haven’t found a solution yet. A while ago Comodo cistray.exe stopped launching at startup, and I received an error message of “Comodo Security Agent Could Not Be Started”. And I had to manually start it. After a while, even manually launching it didn’t work. The process showed up in task manager, but Comodo wouldn’t open. I tried uninstalling and reinstalling. No use. However, even though the tray icon didn’t show up and I couldn’t actually launch the GUI, apparently it was still blocking foreign programs, because my browser would connect to the internet, but not any “unknown” programs. So theoretically the program was still doing its job, just completely inaccessibly. This was not helpful for when I needed programs to connect, so I deactivated the msconfig startup entry for cistray. Strangely enough, cistray.exe still started on bootup and I couldn’t get it to not start, or work properly, so I just uninstalled the whole thing.

I have been very concerned, because I really love having a firewall that asks me about everything that tries to connect – puts the power in my hands. I am concerned that it stopped working because of some subversive malware, but I have run literally a dozen different malware searching utilities including rootkit utilities, none with any effect. Is this actually a malware issue, or WHY is Comodo refusing to work anymore? Can someone please help? I am very distraught over this significant issue with my computer’s lack of internet security.

Thanks!

The technique below, is by no means original.
I stumbled upon at least 2 successes, after serching for … Security Agent.
Kudos to those guys.

Thus far, it has worked for me.
After a reboot, we shall see.

How I did it, after I had to learn some stuff online:
(Win Vista Home Premium)

  1. Left Click … Run

  2. Type in … services.msc

  3. L Cl … OK

  4. Window for … Microsoft Management Console … pops up >
    L Cl … Continue

  5. R Cl … COMODO Virtual Service Manager

  6. L Cl … Properties

  7. On General tab, change … Startup type … from Manual, to Automatic

  8. L Cl … Apply

  9. L Cl … OK

  10. Close … Services

I have a shortcut to COMODO, on my desktop.

  1. R Cl … COMODO Shortcut

  2. L Cl … Run as administrator

COMODO fired right up.

–Hope this works as well for you (& others), as it has–thus far–for me.

Well the latest version 8.0.0.4508 DOES NOT solve this issue

I updated 7 computers out of 8 this morning and all went perfectly. Thank you Comodo for the latest update

The troublesome computer I had hoped would be “fixed” by the latest version in fact was worse (took out the network internet connection)

Same old story repair message boxes and no fixes…removal solved the internet connection

Can we please have a concerted effort to consolidate the various “solutions” spread throughout the forum on this same problem with the hope that something can be done/found and some light at the end of the tunnel with the computers stuck in the installation process

Thanking all in advance

this did not work for me