"Comodo Security Agent could not be started" Error Every Time Comp Boots [M1315]

A. THE BUG/ISSUE (Varies from issue to issue)
Can U reproduce the problem & if so how reliably?:
I haven’t got this issue on my other PC:s, it only exists on a specific PC.

If U can, exact steps to reproduce. If not, exactly what U did & what happened:
1: Boot up windows.
2: Every time Windows starts I get an error saying “Comodo Security Agent could not be started”.

One or two sentences explaining what actually happened:
I got error message “Comodo Security Agent could not be started…” and then Comodo asks “Would you like to run diagnostics tool to fix this error?” This happens every time I start my computer. Sometimes the diagnostics tool finds some errors it can’t fix automatically and sometimes it doesn’t find anything. I’m able to use Comodo normally after diagnostics tool searches for errors.

I have now also noticed that Comodo forgets Firewall rules even though I have clicked “don’t ask again for this app”. This may be related.

One or two sentences explaining what you expected to happen:
When CIS starts it should not pop up any error messages.

If a software compatibility problem have you tried the advice to make programs work with CIS?:
I don’t know if it is or not. I tried to uninstall Avast but it didn’t help. Here https://forums.comodo.com/firewall-help-cis/comodo-security-agent-could-not-be-started-t106696.0.html qmarius asked me if Avast has all modules running so that’s why I uninstalled it but it didn’t have an effect. Thus, it doesn’t seem to be related to a compatibility problem.

Any software except CIS/OS involved? If so - name, & exact version:
I don’t think so.

Any other information, eg your guess at the cause, how U tried to fix it etc:
I have attached a diagnostics report, and KillSwitch Process list, to this post.
Additional reports can be found from this topic here: https://forums.comodo.com/firewall-help-cis/comodo-security-agent-could-not-be-started-t106696.0.html
Here are direct links to them:
Comodo Forum
Comodo Forum
Comodo Forum

B. YOUR SETUP
Exact CIS version & configuration:
Comodo Firewall 7.0.317799.4142

Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
D+ / HIPS is disabled

BBlocker has only Advanced options enabled: “Do heuristic command-line analysis for certain applications” and “Detect shellcode injections”

Autosandbox: Disabled

I’m using Comodo as a firewall only, not as an antivirus.

Have U made any other changes to the default config? (egs here.):
Only user interface changes, but I don’t think they could have an effect.

Have U updated (without uninstall) from CIS 5 or CIS6?:
No.

 [b]if so, have U tried a a a clean reinstall - if not please do?[/b]:
  I did a clean install, but it was not able to fix this.

Have U imported a config from a previous version of CIS:
No.

 [b]if so, have U tried a standard config - if not please do[/b]:
  NA

OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
Windows 7 Professional SP 1, 64bit, UAC disabled, Admin, Not using virtual machine

Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
a= Avast as Antivirus that is running all the time, Spybot, Malwarebytes, Superantispyware b=Previously mentioned + Kaspersky Anti-virus (I’m not sure if it was 2013 or 2014)

[attachment deleted by admin]

Thank you for submitting this bug report. Please try reinstalling by following the advice I provide in this topic and let me know if that is able to solve this issue. Be sure to run all removal tools, including the one for Avast, from Safe Mode.

Let me know if you have any questions.

Thank you.

Hi, thank you for your reply. I already tried that guide as suggested by qmarius, but it didn’t help. That’s why I was told to post a bug report here.

Thank you. Please directly attach a diagnostics report to your first post.
Also, please create and attach a KillSwitch Process list to your first post. If you are not sure how to do that please feel free to ask.

Thanks.

PM reminder sent.

I did it now. I hope I attached Killswitch list correctly.

Thank you. I made some edits to your first post. Does everything look correct?

I made an edit too, it’s ok now.

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again.

Thank you also!

Juhaaa, please see the bug report here:
https://forums.comodo.com/bug-reports-cis/periodic-boot-error-comodo-security-agent-could-not-be-loaded-t102007.0.html
and let me know if you believe that this issue which you are experiencing is likely the same as that already reported.

Thanks.

Well, my problem is not fixed by rebooting. It occurs every single time I boot up Windows.

That’s why I don’t think its the same. (Sorry I could not find edit-button.)

Thank you for checking that. I have updated the information in the tracker. Also, about editing, I’m afraid that editing is disabled for this section of the forum. Thus, if you have something else to add it’s absolutely fine to post a new reply.

Thanks again.

I have been informed that there is some additional information which will likely be helpful.

  1. When does this error message arise? Does it show up nearly immediately after Windows loads, just before the CIS icon appears, just after the CIS icon appears, etc…?
  2. Is cmdagent listed as running under control panel ~ services?
  3. If you wait long enough (such as 30 minutes) is CIS able to run correctly, or is it necessary to always run the diagnostics?

Please let me know if you have any questions.

Thank you.

1) When does this error message arise? Does it show up nearly immediately after Windows loads, just before the CIS icon appears, just after the CIS icon appears, etc…?

Error message shows up immediately after the login screen has passed if my computer starts quickly. Sometimes when my computer starts slowly anyway, the error message shows up a while after the login screen has passed, but the error shows up before desktop icons have loaded. If you ask about CIS icon at the tray, it does not appear there at all. I have to launch Comodo through shortcut, after passing the diagnostics.

2) Is cmdagent listed as running under control panel ~ services?

No, it’s suspended.

3) If you wait long enough (such as 30 minutes) is CIS able to run correctly, or is it necessary to always run the diagnostics?

I always have to run the diagnostics. And after that I have to start Comodo manually, it does not start automatically.

If I refuse to run the diagnostics and try to start Comodo through a shortcut, it asks me again to run the diagnostics.

Thank you very much for your very detailed responses. I have passed this information to the tracker and will keep you informed.

Thanks again.

Juhaaa, if you are able, would you mind testing this for the newest Beta release? It can be found here. The reason I ask is because there was a similar issue reported, which was fixed with the Beta. It would be helpful to know if this is already fixed with that version as well. However, if you are not comfortable running Beta software I understand.

Thanks.

I tried that version, but the problem still persists. Now I actually got 2 different notification window, both containing the very same error message. So things went worse… :-\

Thank you for checking this, and I’m sorry to hear that it’s not fixed. I have added this new information to the tracker. Hopefully it will prove very helpful for the devs.

Thanks again.