Comodo Secure Shopping popups don't show up

I tried to run Comodo Secure Shopping from tasks, it was downloaded so now I’m able to run in the “isolated desktop”.
BTW when I visit a secure shopping site I expect to be alerted by CIS (in order to choose how to visit the site), but this doesn’t happen.

The config screen is attached, what can I check?

I installed Comodo Dragon and it seems to work.
So I tried with other browsers to see if they show the popup, this is the situation:

  • Edge: working
  • Comodo Dragon: working
  • Chrome: not working
  • Opera: not working

Can you explain how you are going to those secure shopping sites? do you type in say or just in the url bar? what OS are you using? I find it weird that in chrome it doesn’t work but does in dragon considering dragon is essentially chrome but with some modifications by comodo.

  • I open the browser and type, then press enter. The site is fully loaded and no popup appears
  • I tried typing both and, the result is the same
  • Browser versions are different: Chrome is version 57, Dragon is version 55
  • I’m using Windows 10 version 1607 (Build 14393.969)

BTW if I start the secure shopping desktop (not via popup), it shows an alert saying that there is a remote communication ongoing.
This is impossible since the PC has been formatted 5 days ago and the only running processes are Dropbox, Comodo and Chrome.

I’m not a fan of unstable software, so I removed secure shopping. At the best, this module is useless for me.

Thanks for the support, I appreciate your job anyway

Detection is achieved with heuristics. False-positives may occur. It’s recommended to report these.
Did you check CSS log? It’s located under : %ProgramData%\COMODO\CSS\verbose.log