Comodo Secure DNS will not stay checked

Not sure how long this has been going on,at least a few days to a week.I would go into settings & the Comodo Secure DNS box is unchecked so i would check it & either close the settings page or close the browser.I would then go back to settings or re-open browser & the box is unchecked again.No matter how many times i try it would do the same thing.I’m on Windows 7 Ultimate 32 bit.
Also when will we see another update?

i do not understand sorry : you have just to write the numbers comodo dns. If you are speaking about checking or unchecking an option in the settings … maybe it is a trouble shooting …

That is what i am talking about…in Advanced Settings.

Hi fenson,
If you are not running 3rd party cleaning programs or have any conflicting extensions, I would consider trying a new user profile or resetting Dragon to defaults found at the bottom of the advanced settings.

Note: A new user profile will remove all personal preferences and settings, including bookmarks.
Tip: I recommend exporting your bookmarks to a HTML file for easy importing into the new user profile.

Note 2: Resetting Dragon removes most personal preferences and settings, excluding bookmarks (See screenshot).

To create a new user profile in Comodo Dragon

Kind regards.

[attachment deleted by admin]