Comodo Secure DNS is down. Workaround for Dragon.

It appears Comodo Secure DNS is down.
Until this issue is resolved please disable ‘Malware Domain Filtering (Comodo Secure DNS)’, found under privacy in Dragons advanced settings.

Thank you.

Edit: The DNS issue appears to be fixed, at my location at least.
I will leave this post for now, in case other locations are still affected by the issue.