Comodo Secure DNS bounded with Yahoo?How secure is this?

Hi!What’s the problem-when I type something in the address bar of my browser(FF), if there’s something wrong with the adress, yahoo tells me that I’m wrong.Why is that?Is this really secure DNS or some way for comodo to implement the yahoo search, instead of the toolbar?Is there some agreement between comodo and yahoo and why nobody tells it, if yes?

My search engine(originally) is google, not yahoo.

[attachment deleted by admin]

This can help. And don’t worry about google logging you, if you don’t have anything to hide, you’re safe ;D
Just kidding.
As far as I know, no yahoo/comodo agreement. There was with Ask toolbar I believe before in the past, but that was dismantled…

How can this help?Google WAS set as my default search engine, but comodo DNS changed it without my permission…Why?And why nobody told me about this?

Comodo DNS does not change search engine. Are you sure you didn’t install any other program with a toolbar?

Yes, I’m sure.Today, I manually changed my DNS to comodo’s secure DNS and that was the result.


I visited the website that you are trying to view,

From what i understand, its a parked domain(Empty Space) owned by Sedo

I’m running Comodo’s Site inspector and also a self created crawler, to see if there is anything on the domain…

Can you do me a favor and run PSC Exam and Upload the results;
also please input the DNS Servers that you have changed (The Address’s)

- Jacob Kilgore
C-O-M-O-D-O Forum Moderator

[attachment deleted by admin]

Later, I promise, because now I’m going out, but just to say-I had “error, server not found” or something, before changing the DNS, now I have a yahoo result.

Are the address’s shown on Switch Now - Change to Comodo Secure DNS Service

Please Correct The Last 2 Digits On Both Address’s

Update: is OK (No Malware Found Virustotal and Site inspector)

Did this help?

- Jacob Kilgore
C-O-M-O-D-O Forum Moderator


Important Note: If you have chosen to install CIS in a language other than English then the DNS Server addresses to be entered are:
Preferred DNS :


Alternate DNS :

Now, really - I have to go!:))

I’m terribly sorry :frowning:

I should have read!

Ok :slight_smile:

So you’re saying that if you look in your web browser, it now says your default search engine is Yahoo? Because it is impossible for this to happen by changing your DNS settings. If the default has changed and you didn’t change it, I would suspect you’ve been infected by malware.

Malware wouldn’t change from Google to Yahoo, it would redirect to predefined web link… ???

Depends on the malware…

Thanks, didn’t know that… :-TU

No, my browser doesn’t say anything.
But you can see what’s on the screenshot, right?

@Jacob, what exactly is PSC Exam?

Yes, I can see the screenshot. However, you were saying your default search engine had changed. Now this does not appear to be the case.

It is quite common for DNS services to redirect users to a search page instead of just giving a DNS error page. I don’t use SecureDNS, but I suspect this is what is happening. Perhaps other users of SecureDNS can speak up about what happens when they mistype a URL?

If SecureDNS is redirecting your mistyped URL’s, you can give the NoRedirect Firefox add-on a try. I used to use this when I ran OpenDNS, but I haven’t used it for a while. You may need to add a custom REGEX to deal with SecureDNS’s redirects. (Assuming that SecureDNS is redirecting…)


HeffeD must be right.
See this video at 9:50 Julian - YouTube.
Remember is a old video, things have changed.


Yes we can see whats on the screen-shot

PSC Exam, is a ‘Analyze Tool’ that generates a report that may help us solve your issue
No Personal Information is gathered, Only Information of your Computer Settings and current state


That’s what i thought, but I can’t find it.

OK, I did a test and it’s not comodo’s fault.It’s something FF related.I changed my DNS to the original state, restarted the PC and did the same search like before.IE gave me an error, not found, but FF gave me the same yahoo result.(see screenshots)The strange thing is that, before i had a page with a comodo’s logo on it, when I’m on a non existent or broken page.This yahoo thing is new.I suspect there’s something with the last FF update.Going to do a deeper search of this.Once again-SORRY, it’s NOT a comodo’s fault! :slight_smile:

p.s.I cannot upload the screenshots.The forum says:“The upload folder is full” ???