Comodo sandboxes bat files of its own "tempscrpt" folder

A. THE BUG/ISSUE (Varies from issue to issue)
Can you reproduce the problem & if so how reliably?:
? It happens by itself once in a while

One or two sentences explaining what actually happened:
? Comodo sandboxes its own bat files
One or two sentences explaining what you expected to happen:
? for Comodo to run these files and recognize them as “Trusted”
Any software except CIS/OS involved? If so - name, & exact version:
? No
Any other information, eg your guess at the cause, how you tried to fix it etc:
? None

B. YOUR SETUP
Exact CIS version & configuration:
? version 10.0.0.6092, everything on default
Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
?
Have you made any other changes to the default config? (egs here.):
? Only to the theme
Have you updated (without uninstall) from CIS 5, 6 or 7?:
? Yes
if so, have you tried a a a clean reinstall - if not please do?:
? Nope, but I assume this issue maybe common with cleanly installed versions.
Have you imported a config from a previous version of CIS:
? No
if so, have you tried a standard config - if not please do:
? Yes
OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
? Windows 7 Administrator
Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
a=? b=? None

https://forums.comodo.com/defense-sandbox-help-cis/cis10-sandboxing-its-own-files-t118322.0.html
https://forums.comodo.com/defense-sandbox-help-cis/auto-sandbox-bat-file-of-cis-t117990.0.html

But it sandboxed a bat file with the lines: "del “C:\ProgramData\cis7342.exe” and “C:\Program Files\COMODO\GeekBuddy\launcher.exe” “unit_manager.exe” “lps-ca”, I checked and cis7342 still exists in ProgramData. Is that suppose to happen?

I guess it is intended. Your issue appears to be easy to solve by trusting mentioned scripts.

Issue can be resolved by trusting the script or use the unblock application task to unblock the script. Moving to resolved.

CIS creates files with random UUID, I wouldn’t say it is fixed if you have to accept each files individually…