COMODO Rescue Disk 1.0.227888.8 BETA Released!

Hello Everyone,

I am excited to announce that COMODO Rescue Disk 1.0 BETA is released for private testing.

What is COMODO Rescue Disk?
COMODO Rescue Disk is a bootable disk image with COMODO Cleaning Essentials for Linux embedded. CCE for Linux is a powerful virus, spyware, rootkit scanner and cleaner. CRD works more efficient than CCE for Windows because it cleans your system before Windows operating system is loaded. It is designed to be used when crimeware embeds itself so deeply into your system that CCE for Windows cannot clean it or Windows cannot start because of any infection or abnormal system change. CRD also provides you with tools to explore files in your hard drive, take screenshot and browse web page.

What needs to be tested?
COMODO Resuce Disk is a new product, all features need to be tested.
The most critical features are:

  1. Ability to detect and clean all virus, malwares and rootkits.
  2. Ability to repair infected MBR and abnormal system changes.

This is a private BETA and must not be used for any other purpose than testing. It can contain serious bugs and must be used only by community members. Please do NOT distribute it outside this forum as it is not intended for end-users even for testing purposes.

Testers can find some useful tools at

Bug Reports:

Please use to report bugs.

Download Locations:

Awesome! been waiting for this for a long time. I will test this out. Hopefully this disk will be adapted for CTM and CB aswell


was waiting for this long time… thanks to comodo developer… :love:

Thanks guy’s this one was really missing in my toolkit :-TU let’s play with it…

idk if this is a bug or a incompatibility with VMware but i can only use the top left quadrant of the screen. it wont let me go anywhere else with my mouse

is anyone else experiencing this?

Awesome!!! Another great tool to add to my collection :-TU. Will be testing this with YUMI.


Hey Great Product…Long waiting came true…

Just now I tested it in Virtualbox. I understand that Killswitch is not required in a standalone bootdisk, that is why it is missing.

But, can’t we have Autoruns Manager in Rescue Disk ?

Because, CCE may not be able to detect everything, we will have a chance to inspect and manually delete or disable the other suspicious autorun entries.

Any idea on whether this release disinfects sality like infections or just deletes them?

Trying to port it on to my USB bootdisk now. I will comeback with more results.

Having issues downloading the base.cav it downloaded to 50% and now tells me ‘Cannot access virus signature database server’.

For production I have a wish to be able to load the bases.cav from a USB drive so you don’t have to download the 100+MB file every time you boot the CD.
(haven’t tested this, so it might already be possbile tough).

It needs to ‘load’ the registry hives to be able to access these locations, but AFAIK it should be possible I have seen other tools that are able to load ‘offline’ registry to investigate.

There are tools that can access and modify windows registry from linux, that is why I thought it would be possible.

There is an option under “Tools” to load bases from local directory, just like in CCE 2.4

Besides, I now tested it on my real system booting from YUMI Pendrive installation.

Everything went fine. Not any big surprises to me as I already have some experience with Linux.

But, I thought /dev/sda, /sde etc… notations could atleast be renamed in CCE detection windows, as it reported my YUMI installation on Pendrive as an MBR modification but it said /dev/sde has an MBR modification, which is not clear to many who are not familiar with linux.

Secondly, I do not know why, it has been saying that a newer version was available and offering to download (funny thing is that I do not have any active internet connection), I thought I would give it a try for fun and I clicked “Download”, it then asked me to select a drive/folder to save to and then does not respond thereafter, the “cancel” button worked though.

The smart scan went really quick and the full scan was also going quickly, I cancelled it of course.

Finally, I am very much satisfied by the initial looks and performance of this great product. :-TU

Happy Birthday… :a0 ;D

One thing makes me wonder, CRD now ‘writes’ to the harddisk on \cce_linux
I’d prefer to write this to a /tmp so you can investigate the target system without ‘writing’ anything to it.

Could this be an option in settings to select where to place /tmp files? placing them on the USB drive would also be an option.
This would leave the scan non-intrusive to the disk/system investigated.


does not work in vmware, I cannot even get to the bottom to hit accept on the screen. This seems to be a reoccurring theme with all rescue discs. Also the mouse is an major issue.

Great work guys!

I could successfully import databases from my local hard disk when I booted from a pendrive.

But, when I am trying to do the same from Virtualbox, nothing happens. It simply shows in about dialog as bases version ‘0’. Update from internet is working fine.

Tried to import several times with fail…

Before import it shows version ‘1’, after clicking import databse it becomes ‘0’.

By the way where is the CCE working directory ? is c:\CCE_Linux the working directory, there is nothing in the scanners sub folder.


Thanks!! I’ve been waiting for this!!! (:CLP)

Waited very long for this thankyou :-TU

Please change the type of guest operation system from “Microsoft Windows” to ‘Linux’(the screen snapshot is attached), then the mouse will works well in vmware.

Best Regards.

[attachment deleted by admin]