comodo reports problems but can't fix

yes i recently tried the diagnostic thing under more, it finished and said there was a problem, as soon as i click yes to fix the problem it says it can’t fix it and asks if i want to create a diagnostic report, so i do but i can’t even read it heh so… i thought i’d post it here and see if anyone has a solution other than the obvius of reinstalling comodo.

had to zip it to get it on here :stuck_out_tongue:

[attachment deleted by admin]

guess no one has any ideas :-\

What problem does it report?Can you post a screenshot? Is one of the components not working?

it doesn’t report any problem at all, it just says there’s a problem it can’t fix and i can’t read the xml report file i attached as when i try to load it all my ram eats up and the program closes ???

Best bet = Clean Uninstall and then reboot twice. Install again. :a0

When uninstalling you can run this clean up tool after the reboot. Then install again.

yes i know but i asked allready in the first post if there was an alternate solution than reinstall, even if the installer has the repair bit it’s greyed out

See if you have other security programs runnning in the background. If so try disabling them and see if that helps.

There might also be drivers left behind from previously uninstalled security programs. Try the following tutorial.

We are gonna take a look to see if there are some old drivers of your previously uninstalled security programs are still around. Go to Device Manager → View → show hidden devices → now look under Non Plug and Play drivers → when you see a driver that belongs to your previous security programs click right → uninstall —> reboot your computer.

When the problem persists make sure there are no auto starts from your previous security programs. Download Autoruns and run it.

This program finds about all auto starts in Windows. This tool can therefore seriously damage Windows when not handled properly. After starting go to Options and choose to hide Windows and Microsoft entries, to include empty locations and then push F5 to refresh.

Now check all entries to see if there are references to your previous security program. When you find them untick them. After unticking reboot your computer and see what happens.

i had to previous security programs before cis4 for as i was using cis3.

no hidden extra Non Plug and Play drivers.

and i’m kinda used to tinkering with the registry in auto run parts
these are the places i look in the registry if i feel something is off with running.
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\run
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\RunOnce
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\RunServices
HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\RunServicesOnce
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\RunOnce
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\runonceex
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\RunServicesOnce
and nothing out of the ordinary there.

this is funny, havn’t yet reinstalled but even with that odd repair thing the prog “seems” to work as intended… wonder what’s gone wrong then ???

Something prevented CIS to install the AppInit guard32.dll on registry see screenshot.
Did you have other security software active during install of CIS? this probably prevented the registration to AppInit.

[attachment deleted by admin]

no i didn’t, it must have happend later and off the top of my head i think i ran that diagnostic test then too when cis4 was new and nothing was wrong.

Then some security software could have removed this entry because it thought it was malicious?

that’s possible, i did run combofix and sdfix once

is there a way to reregister this thing or do i really need to reinstall to get it fixed and if then is there a way to save my rules in the firewall and d+ and overall configs so i don’t need to actually add them again… since i installed they have become many.

What’s your OS version? Win XP/Vista/7 and is it 32 or 64 bit?

xp pro sp3 32bit

Save this as a AppInit.reg and import that in to the registry, next reboot and see if it’s fixed.


Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Windows]
"AppInit_DLLs"="             C:\\WINDOWS\\system32\\guard32.dll"
"LoadAppInit_DLLs"=dword:00000001

can not be imported.
btw this key is completely empty
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Windows

Try this file please.

Please remove .txt before importing.

[attachment deleted by admin]

this is just grand… i got fed up with the trouble now and uninstalled and now cis4 wont install, it stops after installing kernel driver or something like that, the does a rollback, none of the cis4 versions work, however cis 3.14 does :o