Comodo prevents Weechat on cygwin from working

I am running Comodo 8.2.0.4703 on Windows 7 x64. All windows updates are installed. The computer is a clean installation with only cygwin and comodo installed. The computer has no malware infection. Comodo HIPS is disabled, only firewall is enabled. Antivirus was not installed.

The issue is: Weechat cannot connect to for example freenode.

Weechat is allowed in the firewall. The logs do not show anything blocked.

When I disable comodo firewall, weechat can connect.

Everything worked fine in Comodo version 5.

Please help.

I need weechat working, any help would be appreciated.

Please I really need someone to investigate this and provide a fix or a workaround. It makes Comodo unusable, forcing me to be temporarily disabling it every few minutes.

Steps to reproduce:

Install a clean Windows 7 SP1 64bit machine.

Perform all windows updates.

Download Comodo Internet Security 8.2.0.4792 from http://download.comodo.com/cis/download/installs/4020/standalone/cispremium_installer.exe

Download Cygwin from https://cygwin.com/setup-x86_64.exe

Start the Comodo Internet Security installer cispremium_installer.exe

Customize installation, untick “COMODO Antivirus”, untick “COMODO GeekBuddy”, untick “Chromodo Browser”.

In Configuration Options, untick “Do not show alerts that request…”.

Agree and install.

Reboot computer.

Start the Cygwin installer setup-x86_64.exe

Search for package ‘weechat’ and select it.

Finish the installation.

Start the Cygwin terminal.

Start weechat by typing weechat

type:
/set irc.look.temporary_servers on
/connect chat.freenode.net

Observe that the connection does not work.

Disable Comodo Firewall.

type in weechat:
/connect chat.freenode.net

Observe connection works.

This is an interesting bug, I can reproduce the issue and will file a bug report. In the meantime, I can only suggest using a different irc client such as hexchat until comodo can fix the issue.

Hi Guys,

QA is on process for this, we will get back to you asap.

Kind Regards
Buket

Hi,

Please try to disable Sandbox and repeat your steps. If this solves the issue - please create an Ignore Sandbox rule for Cygwin installation directory, enable Sandbox and try again.

I tried the steps again, with disabling Sandbox, and then also with disabling the entire HIPS. Same problem happened - weechat could not connect.

Hello Marilyn,

Thank you for the feedback, our QA will contact you to fix your problem.

Kind Regards
Buket

Hello Marilyn,

We’ve reproduced the BUG and assigned to our DEV team for fixing.

We’ll do our best to fix it in the next version.

Thank You for Your time and attention!

[i]–
Sincerely yours,

Yuriy Malyi
QA manager
COMODO Ukraine[/i]

I have the same problem. Can you please post the workaround/fix here?

I hope I don’t have to wait for Comodo 9 to get weechat working.

Hi blueflash,

Possible workaround is to disable Firewall.

The problem should be fixed in next version.

[i]–
Sincerely yours,

Yuriy[/i]

Yutiry. Will the next version be number 9 or will there be a service update for 8.2?

Hi EricJH,

For now it is planned for version 9 Beta, in case we need we may also plan to make a hotfix release for V8.2; under discussion.

For your information,

Kind Regards
Buket

Thank you. :slight_smile:

This issue still exists in the current release of CIS - did the fix make it to the release version? I would love to come back to using Comodo, but sadly this issue is making it currently impossible.

This is fixed in the new CIS beta 10.0.0.5144.

It has been over a year, the issue was clearly described, reproduced, a fix is internally available, but publicly Comodo is still not working. Please help.