Comodo preventing safe USB drive removal

Hello all, my first post here.

I just installed Comodo IS on a PC I just build.

When I want to remove a USB flash drive using "Safely Remove Hardware and Eject Media " via the tray icon I get the message:

“This device is currently in use. Close any programs or windows that might be using the device, and then try again.”

I find it good practice to scan the entire drive in “my computer” before copying any files to my SSD/HD instead of view contents, copy and then scan them on SSD/HD. The described behavior only occurs in case of an “entire USB drive scan”.

I looked in the Windows administrative events via run\eventvwr and I found that Comodo "stopped the removal or ejection for the device USB " etc.

Is there a setting i could try to avoid this behavior? Or could it be a bug?

Greetings from the Netherlands

Windows 7 x64, fresh install
Comodo version: 6,2 (The very latest, I used the internal update option today)
I mainly used Chiron’s tutorial for configuration, with little alteration, on:

(I am not on the new build PC right now, but if it is important I can look up how my settings differ in about 10 hours after now)

*(edit: removed typo)

Ok, the problem seems to have solved itself.

For future reference some extra information:

The problem occurred using right click\scan with Comodo on the pen drive in My Comuter.
After a fresh format of the USB drive I put some files on it again and after a scan I could not safely remove the drive.
There were no other programs using the USB stick. (Using Windows Explorer, I just copied a couple of 2 to 10 MB files of a very fast 3.0 Drive, a Sandisk Cruzer Extreme, 220MB/sec advertised, above 150MB/sec irl. So the copying process must have been completed after a second or two).

Today I tried again, now using the Comodo GUI\Scan\Custom Scan. After the scan I could now safely remove the USB drive. Then I tried the right click route and that worked as well.

If the problem reoccurs I’ll be back in this topic. I remain interested in any remarks on this subject.

*(edit: added info)

Well, here I am again. Allready.

The problem is back as described in my first post.

I reset my Windows partition to fresh Windows image and installed the CIS version 6,2,282872,2847
from the website. All worked fine. Then I got a program update to 6,2,285401,2860
The install took 8 seconds. After reboot I got:

NSIS Error: Error launching installer

Comodo log says I am running 6,2,285401,2860 now though.

Now I can’t securely remove my USB drives anymore. No other problems seen yet.

Please help.
Should I move to another subforum?

Okay, this is a strange problem, and not one I believe I’ve seen before.

Please try reinstalling CIS by following the advice I give in this topic. Then install the newest version from this post. Be sure to run the removal tools for any other security programs which were once installed on your computer, but are now uninstalled. This could be caused by a conflict of some sort, even if the programs are removed. Also, reinstalling by following those methods is able to fix most issues I have seen reported.

In addition, please list all other security programs, and maintenance programs, currently installed on your computer. This also may be a conflict with one of them.


Thanks for your reply, Chiron.

I just unpacked a clean Windows Image again. No uninstalling necessary. This image contains all Windows updates including SP1 until say last month. I let it update and as for today I will get 7 updates including IE10 (about fifth time since thirsday so I know I’ll get 7 :slight_smile: ).
Allready installed are motherboard drivers. Videocard is not recognised yet, driver will be installed after Comodo IS.

I will start installing:
Line 1. sandboxie 4.05.09 (stable beta fixing Firefox issues, amongst others)
Sandboxie should work fine since about 3,6 (fixing minor issues), no trouble reported combining with CIS.
Why sandboxie first:
sandboxie first because I hate it when installers pop up browsers unsandboxed
sandboxie first because it is my main security program
sandboxie first bedause it is the reason I switched from Avast to Comodo

Line 2. Ccleaner because I want the following images to be clean

That’s all before installing CIS.

I tested allready on this image using FF plus the add-ons I use, I tested drivers but with other security software.
I repeat: all testing was in another image instant. Even after testing I allways start with unpacking a clean Windows image, building up a clean line of several images during build up.

I am thinking now: I am using my first SSD. Before, on a HDD, I would never format (not even quick) before unpacking an image (using Ghost) on my C:
I thought this would be fine on an SSD as well. I found nothing on this topic quick searching the web. I am now using Symantec System Recovery. (VERY fast, unpacking images in 120 seconds). I don’t think this is an issue here though.

I’ll be on F5 whilst installing :slight_smile:

Ok. I installed 6,2,285401,2860 from the download Chiron mentioned (so not via update) on a fresh Windows image as I described in my last post.
The problem with USB devices persist.

As I expected the error message NSIS Error: Error launching installer did not occur though. (This is update-route-related I think).

Stil I can’t use my pc normally… Comodo “hijacks” my USB device according to Windows.

Just to make sure, did you reinstall by following the advice I gave in this topic?

If so then please temporarily disable Sandboxie. Then make sure that the problem persists.


This is what eventvwr says, I am sorry it is in Dutch:

“Toepassing \Device\HarddiskVolume2\Program Files\COMODO\COMODO Internet Security\cmdagent.exe met proces-id 952 heeft het verwijderen of uitwerpen van apparaat USB\VID_0781&PID_5580\AA010206130956321275 gestopt.”

And I try to translate…:

“Application \Device\HarddiskVolume2\Program Files\COMODO\COMODO Internet Security\cmdagent.exe with proces-id 952 prohibited revoval of or ejecting Device USB\VID_0781&PID_5580\AA010206130956321275”

Sorry Chiron, missed your reply.

Please reread reply #4 and I quote myself:
“I just unpacked a clean Windows Image again. No uninstalling necessary. (…)”
“I will start installing: (…)”

I tested:

Disabling Sandboxie (complete shutdown) with a “locked” USB drive left the drive “locked”.



sandboxie running, penn drive in, remove safely, no problem
sandboxie running, penn drive in, scans penn drive with comodo, can NOT remove safely


sandboxie running, drive in, copy data to hd, remove safely, no problem
sandboxie running, drive in, scan drive with comodo, remove safely, no problem
sandboxie running, drive in, scan drive, copy data to hd, remove safely, no problem
sandboxie running, drive in, scan drive, cut data to hd, remove safely, no problem

I have to go to sleep now, it is the middle of the night and have been busy with keyboards and looking at screens for hours. Tomorrow I will continue.

Does the same thing also happen when Sandboxie is not installed? If so we may be looking at a bug.