Comodo (possibly) broke Chrome

Hey,

So a few days ago my computer got the Internet Security Essentials installed. (i always love unwanted programs getting installed on my computer without any notice)
It basically blocked every site i visited, or rather asked me if a really want to visit it or block it, even sites like google.com. So i obviously uninstalled it like any sane person would do with unwanted programs.

Ever since then Chrome throws “Your connection is not private” at almost every site i visit. I already tried resetting and reinstalling Chrome which fixed most sites like google and youtube, but many are still broken:

http://static.fjcdn.com/uploadTemp/89e9d2a9d020e391b0a3a481e9ebb03c.jpg

And also a few sites are showing up blank, (like patreon or chrome support site for example). Page source looks fine and disabling extensions or incognito mode makes no difference.

http://static.fjcdn.com/uploadTemp/8960088abfc415d4f39c0a6c794174d3.jpg

I already tried GeekBuddy which turned out to be utterly useless so here i am asking for anyone if they can help or at least tell me if it is indeed Comodo’s fault. (altho i can’t see how it couldn’t be, since everything was fine before ISE)

So could anyone tell me how to fix it?

Thanks in advance

Try to uninstall “Internet Security Essentials” via config/programs and items. Reboot.

I already said that was the first thing i did and all the problems i currently have started after uninstalling it.