Comodo pop-up messages


I apologize for my english because I’m French.

Little problem with Comodo Firewall ( version ) : sometimes I must reduce all my windows to see a pop-up window asking me if I allow an application to connect to Internet.

Can someone tell me why ?


Hi, does it by any chance happen because you click somewhere in the GUI (the interface of the program you’re launching), making that window active and thus the Comodo alert inactive? In other words, a result of how Windows handles windows?


This may happen when using full-screen applications, such as games. A simple Alt + Tab should reset the focus in that scenario.


Hi Little Mac

I don’t use full-screen mode : I was using firefox and I didn’t get any answer. By reducing firefox, Comodo told me that an application tried to modify the interface. It was waiting for my answer.

After I’ve clicked on “allow”, firefox replied.

The only thing I can think of, is that at exactly the right moment (ie, just as the popup was about to appear/was appearing) you clicked on something within FX, thus maintaining the focus on that application and causing the popup to go to the background.

I’ve had that happen a couple times; very rare, since the timing has to be just right…


I send you the screen of firefox ( I was waiting for an answer ).
I reduce it, and I see a comodo pop-up.

[attachment deleted by admin]

My apologies; I thought your question was why the popup was behind Firefox, not why there was a popup…

The alert you show in the screenshot warns that Firefox.exe, with a parent of ExeGo.exe has been sent a special windows message from AllChars.exe. This type of alert is related to Application Behavior Analysis (ABA), found in Security/Advanced/Application Behavior Analysis.

It is not uncommon for these windows messages to be used. The time to be concerned is if you are not familiar with the applications involved. If you know both firefox and AllChars, you are safe to Allow with Remember, so that you will not see this exact alert again.

I hope I have answered your question.


You were right.
My question was : why the Comodo pop-up window doesn’t appear.
I must reduce all windows to see it. I’m not sure it’s like that it should work.

My apologies again, then. (:SHY)

I do not know why the popups do not have the focus; it should not be happening that way.

Does it happen every time?

Does it happen with just one application?

If not, does it happen with all applications?

Has this happened ever since you installed CFP?

When you installed CFP, did you have any other security applications running actively (anti-spy, antivirus, HIPS, registry protection, etc)?


I have some other applications ( spyware terminator, prosecurity ) and recently comodo antivirus.

I will modify advanced configuration / application behavior analysis to check “monitor windows messages”. In the past, I had a lot of pop-up windows ( interface modification ) so that I have unchecked this option.

The problem comes with different applications. I’ll try to give you more details when the problem will appear.

I think it might be good to start over with CFP, in this manner:

  1. Reboot into SafeMode.
  2. Uninstall CFP via Start/All Programs/Comodo/Firewall/Uninstall
  3. Reboot into SafeMode.
  4. Clean the registry (easiest way is to use an application like RegSeeker or ccleaner) - be certain to create a backup before deleting any registry items
  5. Reboot into SafeMode.
  6. Reinstall CFP.
  7. Reboot normally.

This way you make certain that no conflicts from other applications occur during the installation, and whatever might be in the registry causing problems (if any) is cleaned out as well.

I suggest that since you say that it occurs with different applications; perhaps something went wrong during the initial installation of the firewall.


I was reading this web page

I click on “home” and I didn’t get any anwser. I reduce firefox ( only active application ), and there was a pop-up window : the same I post earlier.

I don’t understand.

If I must reduce all windows to see whether there’s an alert …

I hope someone will find where the problem comes from .