Comodo PF + Firefox

Well, I have problems with FireFox. Every time a FF plugin is updated
(and in some other situations) Comodo starts asking me if I want to
allow connections for FF. It could be ok by itself, but the problem is
that Comodo forgets options selected for FF. Every time I set “Skip
advanced security checks” and clear “Allow invisible connections”.
Every time after updating something in FF I see “Allow invisible connections”
checked and “Skip advanced security checks” unchecked. I change the
options to what I want, click “Ok”, then open the same options again
and they are still wrong. Then something happens (probably I exit and
restart FF - I’m not sure) and the options are finally remembered. Next time
I update FF or plugins everything starts again.

Piglet, a quick explanation of what happens when FF updates itself or extensions/add-ons/plugins:

FF will almost always restart; when it does so, it is starting itself, so thus it is “invisible.” You will get a popup about that, and about the changes in components/library, etc. They may be combined on one alert.

To avoid the scenario you describe, simply click Allow without checking the “Remember” box (if it’s already checked, uncheck it). Let FF open to complete its update process. Then you can close it and reopen. When you reopen it, you’ll get an alert about the changed components, which you can Allow & Remember.

Then your existent rules should remain intact (depending on your Alert Frequency matching your rules detail, of course).

LM

PS: I moved this to the Help boards, where it will be better addressed.