Comodo Personal Firewall - Pop Ups

I am a newbie to Comodo Personal Firewall so it is probably not surprising that I am having some problems. So please can you share some expertise with me.

I have the latest versions of Firefox and Thunderbird on board with limited rights ie I am using DropMyRights. In addition I am using GESWALL (a sort of sandbox type application and variants) The Firewall is set on learning mode and I have not reset or adjusted anything else in relation to the program.

I am getting a plethora of pop ups asking whether I want Firefox or thunderbird to act as a server and whether it should connect to the internet. Some of these contain a tick box to allow and remember. Which I have ticked in all cases.

  1. Should a mail client and browser be allowed to act as a server?

Then there are other pop ups ask the same questions without tick boxes which I just press a button to allow.

  1. The problem is it is in learning mode but does not seem to learn. It keeps popping up the two types of boxes including the same tick box. Am I missing something here? How can I get Comodo to settle down to a steady state with the minimum of pop ups.? Currently every time I open up these programs I am having to validate them as described above

PLEASE NOTE I AM NOT TECHNICAL So any help requires to be idiot proof

Many thanks


If I’m not mistaken, GESWall implements functionality that is already present in CPF. Somebody that knows the program better will be able to confirm it.

But if it is true, then you probably need to uninstall GESWall since you’re practically trapped in a conflict. Just like you should never have 2 antivirus software packages installed, or 2 firewalls installed, you should never have 2 “ApplicationWalls” installed. They step on each other’s toes and in the end nothing works properly.

Thanks for your response. Perhaps other forum members could confirm your observations or point me in the direction where I can confirm it

Thanks again


I quickly read what GESWall does, and I can’t see how it would conflict with CPF.

I think that the plethora of popups are “normal”, as every firewall needs some training in the beginning.

One of the features of CPF is to check the application against it’s list of about 10,000 “safe” applications. You’ll notice that the popup also hase a safety guage on it’s top/right corner. If it is autochecking the tick box, it is because it feels that the application(s) involved “should” mean that the actions are safe, but you are the final judge on that… which is why it is asking you.

If you want to let CPF decide on it’s own for “safe” application it knows, you may want to try the Automatically approve safe applications option in the Advanced section.

Another feature you may want to turn on just below that is Basic popup logic (less number of popups).

Thanks agin for the reply.

I uninstalled GESWALL and the problem of pop ups disappeared after ticking the box and clicking on allow. So It would seem that THEFIREKNIGHT was correct in his analysis that their is a conflict.

I reinstalled it and the pop ups start flowing again

What I really need to know is whether Comodo PF has duplicate features of GESWALL or whether there may be some other cause. I am a great fan of GESWALL I think it is highly secure so I don’t wish to dump it unless Comodo PF does indeed have the features of GESWALL. Indeed the problem may not be GESWALL but just possibly Comodo PF?

Please can anyone shed any further light on this problem of pop ups/compatibility

I refer to my previous post. I have included here a one of the Firefox Pop Ups. I thik it might be relevant.

Grateful for comments on the last two posts.



[attachment deleted by admin]

I have just installed GesWall and testing it. I see the problem that you describe. Try to activate the option “Skip advanced security checks” for firefox. Maybe it will solve it


Thanks for your reply.

Tried your suggestion (By activating in Comodo PF the “Skip advanced security checks”. Unfortunately it did not work.

Keep the suggestions coming



ps GESWALL is a superb product if its possible to get Comodo & GESWALL working together then…!!!

You are welcome.

After testng it a little I think that for the time bing you’ll have to disable “Application Behavior Analysis”. Since GesWall does not let CPF access the application when it isolates it from the system. I can’t figure another way around :-[


Again thanks.

Sorry to be the harbinger of bad news. But disabling “Application behaviour Analysis” makes no difference Pop ups still keep coming. The only thing that stops it is uninstalling GESWALL which as I have said I don’t want to do.

If you can find the time keep the comments coming

Thank you again


Yes the problem is GesWall does not allow CPF to access sanboxed applications. Giving “cmdagent.exe” with FULL access rights in GesWall would be a possible workaround.

Egemen after trying GesWall I saw that this feature does not exist, at least at the free version. It totally isolates the programs from the system. Works like the prefetch feature of xp. Could you please install it and give it a try?

Hi Terry. Maybe I have found the solution at your problem (at least I think so)

Open the GessWall Console. Go to “applications” and then “system”. Then select “Add Application” and use the following:
Display Name : Comodo Personal Firewall (or anything you like that reminds you it point to CPF)
Filename :C:\Program Files\Comodo\Personal Firewall\cpf.exe
Identify by: “Name”
Security Level: “Always trusted”

This should let CPF have access on GesWall and the popups must desappear. On my pc it worked.
Give it a try and tell me know if it solved it.

I have to correct myself. It worked only temporary. :’(
Egemen we need your help on this.

ps.GesWall seems to be a great product. I think that I’ll keep it on my PC even if it causes popups on CPF ;D

We will test GesWall but to solve this problem you must give cmdagent.exe full access right. Not to CPF.exe


After all the work yesterday I went to bed early so I am only just catching up with the flurry of activity.

Again Thanks to all for your help. But everyone will benefit because in my limited opinion GESWALL is one of the better functioning sandbox type applications it works smoothly not like one I could mention (but won’t out of deference to protocols).

Now returning to the question in hand, HOW do I give “cmdagent.exe” full rights of access. Is it via GESWALL ?



Toedgmen & pandlouk

I tried the suggestion that pandlouk mooted in his last post by going into GESWALL console and repeating his instructions BUT I substituted “cmdagent.exe” as per edgemen’s comments.

Unfortunately no joy

When you click on these popups there is a tendency to get a reprieve for a short while and up come the pop ups again. So, over to to you again I am afraid.

Thanks for the help


I did as pandlouk suggested via the GesWall console but substituted cmdagent.exe as per egemen’s post. Unfortunately it did not work made no difference so I await egemen’s tests with interest.

I have a feeling that Comodo & GESWALL would make a fearsome combination if the pop up issue can be cracked

Thanks again to all

I have tried it too; but no success

To pandlouk

Thanks for your reply grateful as usual. Someone said in an earlier post that they were going to test “it”. Does this refer to Comodo & GESWALL and is it just being tested by another forum member or Comodo itself?


We will try to test with it. But currently we are busy with the BETA release. So we will inform you.