Comodo Personal Firewall (CPF) blocks Nero Home [resolved]


When I have CPF turned off, Nero Home can view my UPnP Media Server that is running on the network. When I have it turned on, it can’t find it.

What can I do to trouble shoot this?

Thanks in advance!!!


Welcome to the forum.
Have you made a trusted zone? (security/tasks/define a new trusted network)

Yea, those were setup when I installed CPF…

attached is an ethereal capture when CPF is turned OFF. I think it has something to do with the SSDP protocol that might not be “working” in CPF.

[attachment deleted by admin]


Can you try adding a Network monitor rule that explicitly allows outbound UDP traffic on port 1900. Make sure this rule is above the catch-all block rule at the bottom of the rules list.

Let us know if this fixes the prob.

Ewen :slight_smile:


I added this rule on CPF’s Network monitor:
Action: Allow
Protocol: UDP
Direction: Out
Source IP: Any
Destination IP: Any
Source Port: 1900
Destination Port: Any

This rule did not work.

Then then tried this change in this rule:
Source Port: Any
Destination Port: 1900

This change didn’t effect the outcom of the aforementioned rule :frowning:
I made sure that this rule is ABOVE the “catch-all block rule at the bottom of the rules list”.

Any other ideas? Maybe the rule I created was not right?


Can you please post a screen shot of your network monitor in full view.
You can also post a copy of your log in the firewall. (activities/logs, and right click and export as html).


I can post the screenshot (see attached) but before I opned Nero Home again, I cleared the log so only relevent info be logged, but nothing was, so there is nothing to post.


[attachment deleted by admin]

Have you tried to change your rule to IN? port 1900 at destination.

Ok, the new rule now is:


still doesn’t work though… :-\

If I where you I would go to security/advanced/misc, and uncheck “do not show alerts for apps certified by comodo”, and check “skip loopback… TCP”, and raise the alert frequency slider to the top.
Reboot and allow and remember everything with svchost and Nero home and so on…
Let us know how it goes.

Finally, success :slight_smile:
doing what you said, after reboot, started poping up lots of svchost and so on popups from CPF and I allowed them all, and then Nero Home started working and was able to view my network UPNP media server :slight_smile:

I just hope this isn’t “too much” in terms of security …

Also, we don’t know why this had to be done in order to get, what seems like a simple application, to work …

btw: “cpf nero home” is first on google, so I hope that if others have this problem, they find a quick answer to it (:CLP)

I’m glad that it worked for you!
Good luck, and just ask in this forum if you have any more question, and someone will be able to help you.
I will put resolved on this thread and lock it.