Comodo on Vista x64

I’ve just downloaded and installed Comodo 64-bit version. Everything starts up fine. I’ve seen many post that had immediate problems at startup… but for my system it’s a different problem of which I also seen a few posts but no solutions.

My problem: when i try to open a game (Counter-Strike and TF2) it starts but then gets blocked by Comodo, which is what it’s suppose to do the first time. Only, I need to wait 5 or more minutes until I get the popup from Comodo. I set it as trusted application and tried starting the game again. Again I had to wait 5 or more minutes for the game to start even though I set it as trusted application. Didn’t get any popups either.
Same happend with HL 1.

Then tried opening TF2 and I had to wait even longer. Got tired of waiting so I stopped the game from launching.

Left 4 Dead launched relatively fast.

Didn’t have problems opening MS Office, Utorrent and some other smalll programs.

My guess is Comodo is scanning the file or something before giving a warning and that is whats taking so long. Or the newest version is just not compatible with vista x64 (yet).

Setting firewall and d+ in training mode didn’t help.

Installed CIS Firewall ONLY and have the settings described in the firewall and defence+ guides.
Also have Eset AV and Spy Sweeper running. Maybe these programs are conflicting with each other?

It could be a conflict with SpySweeper. Do you have CIS AV active also?
Try disabling all the AV first. If everything is fine, add back the AV one at a time.

No CIS AV. Only installed CIS Firewall.
I’ll try and see if switching other security programs will help.


It seems indeed that Comodo doesn’t like SpySweeper. When SpySweeper is turned off my programs launch as they should. It doesn’t seem to conflict with Eset.

So basically it’s Comodo or SpySweeper. That’s a shame.

As an alternative to SpySweeper, you could use SuperAntiSpyware. It does not seem to conflict with CIS.
I have used this app myself as on-demand with great success.

I was thinking about Spyware Doctor. But if SuperAntiSpyware is considered better I’ll try that one first.

I bailed on SpySweeper over a month ago because it was interfering with too many other applications.

I use SuperAntiSpyware and Malwarebytes Anti-Malware for on demand scans and neither have an issue with CIS.

Got stuck when trying to open a mounted image file in deamontools. Had Spyware Docter installed but still got stuck after I removed Spyware doctor.