Comodo not stopping sharing on windows 7 64

Hi all

Now i have used a many firewall & and this is the first one i have ever used that has still allowed windows sharing feature with out me informing it to.

Now i do stand to be corrected & i am hoping that i am just configuring this firewall wrong.

So my question is how do i stop windows sharing except for the computers & or applications that i want to be shared for example like a proxy server.

Please help thank you!!

Edit by EricJH: changed the all caps to normal case. Please don’t shout it is impolite.

With default settings not allowing incoming traffic for System should do the trick.

Can you show me a screenshot of your Global Rules?

Yesir!!! & sry about the caps

[attachment deleted by admin]

I see you have four rule sets for trusted local networks. Remove all rule for Local area network #1 to Local area network #4 in Global Rules and System. That should disable sharing.

No it has not stopped sharing, as a matter of fact the only setting on this firewall thats stops sharing of any kind is the stop all activity button. of course it also stops me from accessing the net as well. is this perhaps a glich. My install is fairly new and this is the first and only security suite that i have installed on this system since the new install.

Did you remove the rules for the 4 lans from System in Application Rules? Can you post a screenshot of the current rule for System?

Ok i figured out what the issue was. :o

i had to disable ipv6. which means this fire must not be v6 ready yet though i have faith that it will be soon??

still i will post this pic incase i am wrong & thank you for taking the time out your day to help me i really appreciate it. O0 :-TU

oh and can this firewall Allow by mac address only

[attachment deleted by admin]

The firewall can filter by several parameters. See the attached image.

Just bumped into this statement from egemen the head developer about implementation of IPv6:

[attachment deleted by admin]