Comodo not recognized in Windows XP security center

I think tittle says all. How to make it recognizable in security center ? I tried to reinstall it 3 times… No effect… It still saying, no firewall is installed. Sure I can disable that notification, but I would like to see it, beeing recognized by windows


Maybe it would benefit you to read this thread:,6864.0.html

It’s a problem with Windows’s repository folder not refreshing.

Unfortunately, I too am experiencing the problem of WSC not recognizing my recent install of Comodo firewall. I’ve now run Ewen’s nifty script 3 or 4 times to delete & rebuild the repository, which does immediately seem to resolve the problem, but 2 or 3 minutes after reboot, the problem reoccurs!!! Any suggestions for a proper resolution or am I going to have to disable the WSC?


There is really no need to deal with windows security center. It seems to be useless… It relays on a service that users usually disable it. Try this site for further information

Doug, your case is the first I’ve seen reported where it returns after a few min.

George0 is right. The only use for that service is for info status to provide “peace of mind” :). Save your self resources (and grief) by disabling it.

Yeah - thanks guys. I’m anal retentive enough that it will bug me a little that I can’t get WSC to play nice with Comodo - who likes being the only one that can’t get it to work??

I’ll probably let it go for a week or so and periodically run Ewen’s batch script and see if it won’t all of a sudden decide to settle down. If no joy, I may decide to disable the WSC service. Maybe I’ll try to uninstall and reinstall Comodo - but then I’ve read that the uninstall does not work so well yet (!)

Thanks for the link to Black Viper - I used to visit his site until he shut it down in '05. See he’s just resurfaced and in N. Calif where the tech gold rush busted years ago…go figure. Anyway, it’s nice to hear from him again - so thanks for the heads up in that regard.


If you decide to uninstall CFP, you might want to do the following first:

  1. Change CFP’s Security Level to Allow All
  2. Go to Security/Advanced/Miscellaneous, and uncheck the box, “Protect Own Registry Settings.”
  3. Turn off all active security that might want to protect system changes (AV, HIPS, registry guard, etc)

Then you should be good to go to uninstall. If you want to go the extra mile, disable the Firewall Service startup type and remove the startup entry, then reboot and uninstall after reboot.


If so you can browse to your windows installation folder /system32/wbem and take a backup of the folder named repository. After backing it up delete it and reboot immediatelly. I have done it a couple of times and the problem solved. \good luck