Comodo makes the Office 2010 Save As dialog extremely slow

When I have Comodo Firewall enabled, the File → Save As dialog box in Office 2010 is extremely slow (switching folders takes 10 - 30 seconds).
I noticed a similar performance drop in the Save As dialog box of other Microsoft programs like Paint and Windows DVD Maker. Up till now, I haven’t come across a non-Microsoft program that suffers from the same problem.

Some more details:

  • Windows 7 64-bit
  • Office 2010 64-bit
  • Comodo Firewall and D+ (no AV): 4.1.150349.920
  • Firewall set to ‘Custom Policy Mode’
  • Defense+ set to ‘Safe Mode’
  • Sandbox disabled
  • All 4 Defense+ settings under ‘Advanced → Defense+ Settings’ are disabled (Trust the applications …, …, Create rules for safe applications)

Steps to repro:

  • Make sure Office 2010 and Comodo are installed (in case Office 2010 is not installed, you can also repro the problem using Paint)
  • Open an Office application (Word or Excel) and open a file
  • Select File → Save As.

Opening and navigating in the dialog box is extremely slow.

When I disable Comodo (exit Comodo), the problem does not occur anymore.

Anyone else seen this behavior? Any solution?
Is this a bug in Comodo?

Thank you!

Are there other security programs running in the background that could interfere? Try disabling them.

Are you sure your previous firewall is properly uninstalled? You can check by doing as follows.

We are gonna take a look to see if there are some old drivers of your previously uninstalled security programs are still around. Go to Device Manager → View → show hidden devices → now look under Non Plug and Play drivers → when you see a driver that belongs to your previous security programs click right → uninstall —> reboot your computer.

When the problem persists make sure there are no auto starts from your previous security programs. Download Autoruns and run it.

This program finds about all auto starts in Windows. This tool can therefore seriously damage Windows when not handled properly. After starting push Escape and go to Options and choose to hide Windows and Microsoft entries, to include empty locations and then push F5 to refresh.

Now check all entries to see if there are references to your previous security program. When you find them untick them. After unticking reboot your computer and see what happens.

It’s a clean installation of 2 weeks ago. So no old security programs have been removed.

The only other security program on the computer is Avast anti-virus. I have disabled Avast during my tests and Avast does not seem to interfere with Comodo.

I also tried disabling all non-Microsoft shell extensions (found this tip somewhere else on the internet), but this makes no difference.

It is only when I disable Comodo, that the save dialog behaves normal again.

I will check the status of Windows Defender and Windows Firewall, just to be 100% sure there is no interference, but it really seems as Comodo is the cause of this problem.

Do the Defense + logs show blocking activity related to Office? Can you post a screenshot of them? he logs are under Defense + → Common Tasks → View Defense + Events.

No the Defense+ logs do not show any blocking activity.

How did you disable CIS?

This looks like a bug to me.

I right-clicked on the CIS icon in the tray and selected Exit, which closes CIS completely.

Do I need to file a bug report? (how?)

Please try the following two ways of disabling D+.

First disable D+ from the CIS icon in the tray and see what happens.

Second disable D+ from Defense + Settings (Defense + → Advanced) by ticking "Deactivate Defense+ permanently(Requires a system restart) " and reboot. Then try again.

Your topic start is very clear. This topic can be moved straight to the bugs board.

I tried disabling D+ in both ways. They have both the same result: once D+ is disabled, performance of the Save As dialog box returns to normal.

I seems this problem is not only affecting Office. I noticed a similar performance drop in the Save As dialog box of other Microsoft programs like Paint and Windows DVD Maker.

It could be another guard64.dll related problem then.