Comodo loses configuration, stops responding for internet

My computer suddenly stopped responding to internet requests while using Comodo 3.0.14. I had a similar experience with 3.0.13, but solved it by uninstalling/reinstalling. This time it happened while I was watching a little closer.

First, the computer would no longer go to https sites (http was OK)
Then I rebooted and lost the internet entirely
Nothing appeared in the Firewall log or D+log, in spite of “block and log” at the end of every application in the Network Security Policy.
I went to the “manage my configurations” display, thinking there might be a corrupted database
Selecting the default configuration brought everything back
Then reselecting configuration I was using when it hung also worked

I had saved a later configuration file, so imported and selected that, now is working fine

Probably not enough information to find the problem, but something to suggest that others try if their Comodo suddenly starts blocking everything and logging nothing.