Comodo looses Stealth Ports setting

“Stealth Ports Wizard” / “Block all incoming connections Stealth my ports to everyone”,
Received dialog “…configured accordingly”, reopened option and dialog shows original setting not the new one.

Is this normal, if not how to get it to retain setting?

Check the global rules (Firewall/Advanced/Network Security Policy/Global) to confirm the settings.
The window you are viewing will always show the first option no matter what you have set.

Note, the Stealth Ports Wizard is not an option that can be turned on or off. It is a process (wizard) that can be run to stealth your ports.