Comodo locks up 32 Bit Vista after memory upgrade


First post - so apologies if it is in the wrong place - tried to find the correct one !

Been running Comodo for over a year (currently 3.10.102363.531) on 32 bit Vista Dell Inspiron 530. No problems. Today I was trying to upgrade my memory from 2GB to 4GB ( 2 extra 1GB sticks). Looks like they sent me the wrong or duff memory. Installed it and bios said 4GB installed 2GB available. Went into windows control panel, system confirmed still 2GB. Comodo still behaving normally. Tried removing 1GB of new. Bios said 3GB installed 2gb available, went into windows, machine locked up after Comodo started up. Obviously took me a little time to check it was Comodo that was the problem, but disabled it in safe mode, and no problems thereafter.
I then tried to revert to just 2GB memory. I took out my orignal Dell memory replacing it with the new , put the new in slots 1 and 3 and bios refused to start - just high revving fan noise. Took out the new memory, put back my old original 2GB back in slots 1 and 3. Winodws starts. So definately dodgy memory - seperate issue.

So now back in my original memory state, I go back into windows I uninstall Comodo, reboot, reinstall Comodo, reboot, and my machine still locks up again. Back to safe mode, disable Comodo, reinstate Windows firewall (aargh) and everything is fine. My first thought was that I might have damaged my original memory taking it in and out, but have just performed a Vista Windows Memory diagnostic test, and the results are clean - no problem with the memory. Second thoughts - I don’t have any second thoughts…

Any ideas anyone?


First off, as you probably know, memory can be tricky thing. Some motherboards can be very fussy about memory… and despite that uninstalling CIS might seem to cure the problem, it actually might not have at all. CIS might have merely stressed/utilised the memory sufficiently to reveal the problem. However, I’m not saying that’s the case here. You need to do more testing… it’s might be something to do with the motherboard (compatibility), the BIOS (always wise to check for updates), PAE (Physical Address Extension), DEP, the actual DIMMs or, of course, CIS (I can’t think of any current reports like this). I recommend you run some memory stress tests, I believe Vista has an inbuilt boot-time one available on the boot menu. It’s not the best & cannot guarantee to find problems, but it’s a good first step. On Vista x32 you should only be able to actually see about 3.3GB or so, because it cannot address the rest.

Did you get the memory from Dell specifically for your system?

Thanks for your prompt reply.

Sorry I should have said that I updated the Bios before I attempted the upgrade - I upgraded to 1.0.18 downloaded from Dell’s site.

As I mentioned, I returned the machine to its original state with its original memory - just the 2GB Dell memory (the extra 2GB if memory was not bought from Dell and will be returned to the retailer).
I then ran a memory test using Vista’s inbuilt diagnostic memory test on that original memory. It came back with no errors report on the original 2 GB of Dell memory.

All my other programs seem to be running OK. Its just Comodo - its probably not even comodo’s fault its probably some dodgy registry entry in Vista caused by my attempted upgrade.

I should also say that being a dual core machine, you should upgrade memory in matched pairs, so the fact that I tried with 3 x 1GB after the initial failure of 4 x 1GB (2x2 matched pairs) wasn’t perhaps too clever.

I think the matched pair issue isn’t necessarily a show stopper issue, it’s more usually just a performance thing.

Does you BIOS/Mobo have PAE support & is it enabled? Without PAE, I don’t think you can go over 2GB. It sounds like it could be PAE (ignoring the extra memory).

[i]Refusing to boot, would be worrying. More than CIS is capable of doing/causing really.

PS Usually a BIOS refusing to start would issue a bleep code (via the system speaker) or flash the code via the keyboard lights. Each code, BIOS dependent, says why it’s refusing to boot.[/i]


I don’t know if PAE Support is enabled, I thought PAE was for over 4GB anyway. How can i tell if its enabled?
Spec wise I’m pretty sure the Dell Inspiron 530 is designed to take up to 4GB fro 32bit Vista.

I don’t think the refusing to boot was anything to do with CIS - It happened when I installed the new bought memory in slots 1 and 3, replacing the original memory. I got fast fan revving sound and no Bios boot up - just blank screen. My only experience of that before was when I had once tried to install a graphics card in a machine that had only 300Watt power source rather than the required 350 watt. So an indication of incompatibility. Thus I assume that the new memory I purchased was either defective or in fact was the wrong memory for my machine. The label on the memory only had DDRII 667 Mhz - it was advertised as PC2 5300 DIMM, which would have been correct but did not have that on the label - so I am suspicious and its going back.

Why CIS now locks up the machine with the original memory is the question. Windows starts. All my startup programs initiate correctly. The Comodo Icon comes up in the tray and everything freezes. No mouse, no Cntrl Alt Delete - just power off is available.