Comodo LivePCsupport Bug report

There is no thread for this yet, so I created this one.

Windows Vista Ultimate x64, SP1, all updates applied.
CIS 3.9 beta (all modules) the only security software active.
MSN Messenger and Comodo eVPN active and online.

Easy to reproduce. (Tried this 4 times, same result each time.)
I started LivePCsupport simply to see what the screen looked like.
A window immediately popped up saying there is a new version available, with buttons to Update or Cancel (I assume cancel the update). I clicked the Update button, and the window just sits there, not doing anything. Left it this way for 30 minutes before canceling this window.
The main GUI did not display until this window was closed.

Is there an actual update available?

Hi,

The bug reproduces when there is no internet connection when you press update button. In your case, I guess your CIS blocked the application.
The bug was fixed, thank you for the bug report.

I added ELPS.exe to the firewall rules (Trusted), but it still does the same thing. Note this time JAVAW.exe popped up asking for firewall permission to access the network. I allowed this, but still nothing.
Does this ‘Fix’ require LivePCsupport be DL’d and re-installed? (if so, when will this be available for DL?)

Yes, this means LPS needs to be reinstalled. The update will be available tomorrow.

Hello,

Please post livePCsupport bugs here: https://forums.comodo.com/live_pc_support_geeks_ready_to_help_247365-b169.0/

Thank you!