Comodo kills some of my other apps

Hiya. Thanks for your time.
I think that the Comodo Firewall software is superb but the only thing which is stopping me from using it is that when I install it, neither Symantec Backup Exec System Recovery or Healthmonitor will even open anymore. If I remove the firewall they both run happily.
The Healthmonitor error I receive is “CLR error: 8007000b. The program will now terminate.” and the message I get from Symantec BESR is “Symantec Backup Exec System Recovery 2010 VProConsole has encountered a problem and needs to close.” and it stamps the message “.NET Runtime version 2.0.50727.4455 - Fatal Execution Engine Error (7A09962E) (80131506)” into the event log.
Any advice on this matter would be appreciated as I’d really like to make use of the software but it’s stopping my monitoring and backup software from running.
Many thanks and best regards,

Add CDBurnerXP, Beausoft Netcam Watcher Pro, WinRar, InfoRad Manager (Speed Camera detection device software), Microsoft Windows 7 Upgrade Advisor and RoboCopy GUI to the list of programs it’s killed too. Apologies but I should have tested all my apps before my initial post.

Thanks again,

May be these programs gets sandboxed. Look under Defense + → Common Tasks -->My Pending Files. When you find executables belonging to the mentioned programs select them and move them to My Own Safe Files and restart your computer.

The sandbox limits the rights programs have and that cause them to stall. Also read the introduction to the sandbox (check my signature) for basics on how it works and how to work around problems with the sandbox.

Hiya Eric. Many thanks for your response.
I’ve tried disabling all available options from within the Firewall gui (SandBox included) and nothing seems to make a difference.
The only way I can get these apps to run again is to remove the Comodo software.
If it helps with the diagnosis at all, I’m quite sure I used to run this software successfully sometime last year until an update to V4 stopped things from working.
The version I’m using now is newer than that one was and some of the other apps I’m running which now fail are also newer versions.

Thanks again for your time.

What version of CIS are you running?

I see programs of which I would expect to run without problems like CD Burner XP and Winrar. Are you running stock settings when this happens?

Did you enable : Block all unknown requests if the application is closed "? If so disable it and see what happens.

I use CDBurnerXP, Winrar too and they work perfectly. Didn’t have to add to trusted list or anything, they both just worked.

May be corrupted My Trusted Vendor list? Try running Diagnostics and see if that helps and what it reports.

Thanks for the suggestions chaps.
Diagnostics came up clean. I uninstalled the app, manually located and deleted all remaining folders, files and registry entries, as well as having run CCleaner to remove any rogue registry entries and references I may have missed including temp files, before rebooting with a chkdsk /f.
I reinstalled the app and still the same issue.
I’ve now performed the above again but have installed V5.0.162636.1135 and it works perfectly so I guess we can safely close this ticket now. Still a strange one though.

Many thanks for your help chaps.